Bug 157704 - okular doesn't display asymptote graphs correctly
Summary: okular doesn't display asymptote graphs correctly
Status: RESOLVED NOT A BUG
Alias: None
Product: okular
Classification: Unclassified
Component: PDF backend (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-12 03:02 UTC by Matthias
Modified: 2008-03-07 17:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
okular screenshot (238.39 KB, image/png)
2008-02-12 03:04 UTC, Matthias
Details
evince screenshot (184.91 KB, image/png)
2008-02-12 03:05 UTC, Matthias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias 2008-02-12 03:02:44 UTC
Version:            (using KDE 4.0.0)
Installed from:    SuSE RPMs

Hi, 

okular doesn't display this PDF correctly:
http://asymptote.sourceforge.net/gallery/3D graphs/sinc.pdf

I have attached screenshots from evince which does it right and okular which doesn't.
Comment 1 Matthias 2008-02-12 03:04:45 UTC
Created attachment 23542 [details]
okular screenshot
Comment 2 Matthias 2008-02-12 03:05:11 UTC
Created attachment 23543 [details]
evince screenshot
Comment 3 Pino Toscano 2008-02-12 10:04:29 UTC
Poppler version?
Comment 4 Matthias 2008-02-12 18:38:41 UTC
> 10:04 ------- Poppler version?

0.6.4
Comment 5 Matthias 2008-02-12 19:18:50 UTC
I just tried with current git, but the problem persists. 
Comment 6 Pino Toscano 2008-02-12 19:27:10 UTC
Works for me with git master.
Comment 7 Albert Astals Cid 2008-02-12 20:20:49 UTC
I'm not sure i can see the problem, can you tell me?
Comment 8 Matthias 2008-02-12 21:06:15 UTC
> ------- I'm not sure i can see the problem, can you tell me?

The transparency is rendered a lot more cleanly with evince. Okular shows 
some kind of grid instead of proper transparency. 
Comment 9 Pino Toscano 2008-03-07 17:37:51 UTC
Sorry, but Okular has no role in rendering the document.
All the job (for PDFs) is done by libpoppler, so you should report the problem to poppler, so it can be better tracked there.

Thanks for your understanding.