Bug 157693 - JavaScript unable to create CrossPowerSpectrum or BinnedMap plugins
Summary: JavaScript unable to create CrossPowerSpectrum or BinnedMap plugins
Status: RESOLVED FIXED
Alias: None
Product: kst
Classification: Unclassified
Component: scripting (show other bugs)
Version: 1.4.0
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kst
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-11 23:34 UTC by Andrew Walker
Modified: 2008-02-19 20:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Walker 2008-02-11 23:34:44 UTC
Version:           1.4.0 (using KDE 3.5.8KDE 3.5.4KDE 3.5.3)
Installed from:    Compiled From SourcesCompiled From SourcesCompiled From Sources
OS:                Linux

PROBLEM:

JaveScript does not allow the user to create an instance of either the "Cross Power Spectrum" or the "Binned Map" plugins.

STEPS TO REPRODUCE:

Start Kst
Show the JavaScript Console
Type in:
pl=new Plugin(Kst.pluginManager.modules["Cross Power Spectrum"])

RESULTS:
Type Error

EXPECTED RESULTS:
The plugin is created
Comment 1 Andrew Walker 2008-02-11 23:35:51 UTC
This is because the two plugins mentioned derive directly from KstDataObject as they provide a custom UI. Thus, there needs to be custom functionality added to the js extension to handle these two plugins.
Comment 2 Andrew Walker 2008-02-16 02:32:55 UTC
SVN commit 775529 by arwalker:

CCBUG:157693 first draft of adding cross power spectrum functionality to javaScript

 M  +3 -3      Makefile.am  
 A             bind_crosspowerspectrum.cpp   [License: GPL (v2+)]
 A             bind_crosspowerspectrum.h   [License: GPL (v2+)]
 M  +1 -1      bind_ellipse.cpp  
 M  +1 -0      classindex.xml  
 M  +2 -0      js.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=775529
Comment 3 Andrew Walker 2008-02-19 01:57:40 UTC
SVN commit 776904 by arwalker:

CCBUG:157693 first draft of javaScript functionality for binned map plugin

 M  +3 -2      extensions/js/Makefile.am  
 A             extensions/js/bind_binnedmap.cpp   [License: GPL (v2+)]
 A             extensions/js/bind_binnedmap.h   [License: GPL (v2+)]
 M  +30 -6     extensions/js/bind_crosspowerspectrum.cpp  
 M  +5 -0      extensions/js/bind_crosspowerspectrum.h  
 M  +2 -0      extensions/js/js.cpp  
 M  +1 -1      libkst/kstmatrix.cpp  
 M  +62 -8     plugins/binnedmap/binnedmap.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=776904
Comment 4 Andrew Walker 2008-02-19 20:56:45 UTC
added cross power spectrum and binned map plugin functionality in javaScript