Bug 157017 - Panel artifacts with openoffice opened
Summary: Panel artifacts with openoffice opened
Status: RESOLVED NOT A BUG
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 90 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 164904 165566 165800 166469 168182 173592 174155 174164 181193 186848 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-31 10:40 UTC by András Manţia
Modified: 2009-11-03 23:40 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2008-01-31 10:40:55 UTC
If I open OpenOffice (from openSUSE 10.3) and openoffice is in visible (even
part of it), the panel, which holds the taskbar goes crazy. See the attached
movie (ignore the sounds).
AMD64, Nvidia FX5500, nvidia binary driver.
Comment 1 András Manţia 2008-01-31 10:53:31 UTC
The movie showing the "effect": http://andras.kdewebdev.org/other/plasma_issue.mov
Comment 2 Leo Spalteholz 2008-02-07 21:24:57 UTC
I can confirm this bug.  OpenOffice 2.3.1 from debian unstable.  KDE 4.0.0.  Nvidia proprietary driver 169.09 on a Geforce 7900 GS
Comment 3 Aaron J. Seigo 2008-02-11 02:16:46 UTC
this has already been reported and there is an open BR for it elsewhere. i can't find it atm to close it as a duplicate though =( it's assigned to Lubos, in any case...
Comment 4 Aaron J. Seigo 2008-02-14 17:48:40 UTC

*** This bug has been marked as a duplicate of 153637 ***
Comment 5 Giulio Camuffo 2008-03-16 16:59:05 UTC
for me, kde 4.0.66 revision 20080313 this bug is not resolved.
Comment 6 Luigi Conversini 2008-03-18 19:28:31 UTC
I have the same problem. Kde 4.0.66 rev 18/03/2008.
Comment 7 Dan Meltzer 2008-03-19 22:49:18 UTC
This bug is actually different than the _NET_WM_ICON, it's not that the icons are not there but that the entire panel starts tweaking out, having rendering glitches, and blinking.

This persists even with the fix for NET_WM_ICON.

Reopening.
Comment 8 Luigi Conversini 2008-04-13 20:06:47 UTC
this problem still persits with the last svn version 4.0.69...
Don't you think it should be fixed as soon as possible??
Comment 9 Troy Unrau 2008-04-24 18:45:40 UTC
I get this bahaviour with firefox and/or xchat open as well - I don't have openoffice installed.

I am using the nvidia binary blob on amd64 (slamd64 12.0)
Comment 10 Aaron J. Seigo 2008-06-16 21:34:10 UTC
i'm not seeing this in trunk anymore; i used to get it with oo.o as well as firefox, but.. seems to work nicely now at various taskbar sizes. can anyone else verify/deny for me?
Comment 11 Yuriy Kozlov 2008-06-19 03:14:15 UTC
I get a similar effect with OpenOffice and Eclipse, and it still happens with a daily build from project Neon:
Version 4.00.82 (KDE 4.0.82 >= 20080610)

I am using Kubuntu 8.04 with the nvidia binary driver.
Comment 12 Leo Spalteholz 2008-06-19 21:14:58 UTC
This bug has gotten a bit less severe, but is still there.   It used to be that just working in Openoffice would make the plasma panel go bezerk.  Now that no longer happens (4.0.82 from debian, OO 2.4.1, nvidia 169.09)

However if I have OO or Kompozer (XUL based app) open and then mouseover the taskbar it freaks out.
Comment 13 Leo Spalteholz 2008-06-20 01:37:46 UTC
Funny thing I just noticed.  This bug is NOT triggered when you open a document in "read-only" mode in OpenOffice Writer (no text cursor (caret?) visible on the document).
Perhaps the text cursor triggers this.

Further testing confirms this.  Start Openoffice Writer, cursor is blinking on a blank page.  Mouse over the task bar to see corruption.
Then click file-open, now the cursor is blinking in the "File name" field.  Mousing over the panel shows corruption is still evident.
Now click the mouse on the files view in the open dialog (so the cursor disappears) and mouse over the panel.  The corruption is fixed.

Hopefully that will help narrow it down for someone with wicked Xorg skills.
Comment 14 Heath Bielefeldt 2008-06-21 06:29:19 UTC
Brilliant find Spalteholz! I can confirm that in Notepad via wine, the corruption occurs with the blinking caret upon starting the program, but when the Print dialog is opened the corruption (and the caret) is gone [it always takes a mouseover to "fix" the panel]. When the Print dialog is closed, the caret is back, and with it the corruption.

[kubuntu 8.04 remix AND kde-nightly; with nvidia proprietary]
Comment 16 Aaron J. Seigo 2008-06-23 00:45:02 UTC
so this is an upstream bug. excellent (for us, not the users of those drivers ;).

Sebastian: feel free to close upstream bugs. they are not useful to us in this BT, especially as we have no effective way of automatically tracking other reports.
Comment 17 Sebastian Sauer 2008-06-23 09:02:34 UTC
yes, bad since I am also one of the nvidia-victims. Grrrr, what a good sample why closed-source drivers just can't work in the long run. Time to buy a intel-card (anyone interested to buy my 7100GS-card? ok, probably the wrong thread for a good business ;)
Comment 18 Bram Schoenmakers 2008-06-25 10:18:14 UTC
*** Bug 164904 has been marked as a duplicate of this bug. ***
Comment 19 Ronan Arraes Jardim Chagas 2008-06-28 17:08:04 UTC
I have the same problem here.
I'm using nvidia-drivers 173.14.09.
Everything is fine until i open Openoffice, then plasma become very strange and doesn't render well.
It happens with and without desktop effects and i don't see anything like that when i'm using another window manager.
Comment 20 Sebastian Kügler 2008-06-30 17:42:51 UTC
This bug should be reported to the NVidia developers via http://bugzilla.freedesktop.org, component xorg, product Driver/nvidia (proprietary)
Comment 21 Luca Gambetta 2008-06-30 19:52:18 UTC
I already filled a bug report some days ago, no reply from no one...

https://bugs.freedesktop.org/show_bug.cgi?id=16541
Comment 22 Sebastian Sauer 2008-06-30 22:27:53 UTC
Well, the Kernel-developers did complain loudly already.

http://blogs.zdnet.com/open-source/?p=2587
"Developers criticize Nvidia, other holdouts for hindering Linux desktop"

http://blogs.zdnet.com/open-source/?p=2588
“NVIDIA supports Linux, as well as the Linux community and has long been praised for the quality of the NVIDIA Linux driver." (yeah, see e.g. this report and dozend others we have within bko)
“NVIDIA doesn’t expect Linux kernel developers to debug issues in NVIDIA’s kernel module.” (aka stick with our bugs or go Intel or ATI)
Comment 23 Marco Martin 2008-07-05 22:03:48 UTC
*** Bug 165792 has been marked as a duplicate of this bug. ***
Comment 24 Jonas Thorell 2008-07-06 00:25:17 UTC
Odd. This bug was gone (on my machine) using 4.0.84 (OpenSuSE 11, Factory repo) but returned with 4.0.85. The nvidia driver in question is 173.14.09.

The fact that it was not present in 4.0.84 sounds like nvidia is not the only culprit (even if probably the major one). Something else is at play as well.

Note though: I only get this using OpenOffice now. I used to get it using firefox as well but not anymore.
Comment 25 Sebastian Sauer 2008-07-06 00:46:33 UTC
Jonas: also taken the finding from comment #13 into account?

btw, for sure there are more components in the stack like the kernel and x.org but since it happens *only* with nvidia and was confirmed by quit a lof of sources (see comment #15) I would be rather careful here to blame them (culprit) for problems they just *can not* solve. Please also do note the official answer from nvidia (comment #22) which results in: *everything* that wents wrong with nvidia-drivers is there problem and nobody else is responsible for it cause "NVIDIA doesn’t expect (Linux kernel) developers to debug issues in NVIDIA’s kernel module."

p.s. that's for sure only my point of view on it as someone who actually would debug if he would be able to.
Comment 26 Marco Martin 2008-07-06 13:01:43 UTC
*** Bug 165800 has been marked as a duplicate of this bug. ***
Comment 27 Marco Martin 2008-07-06 16:09:24 UTC
*** Bug 165566 has been marked as a duplicate of this bug. ***
Comment 28 David Strozzi 2008-07-11 18:00:52 UTC
To add more data to this nominally resolved bug:

I am running opensuse 11.0, updated kde to 4.0.85, on amd64 chip, with nvidia driver 173.14.09, and openoffice 2.4.1.  When running oowriter, the whole panel (taskbar, icons) and plasma amoeba in the upper-right corner go crazy (become black or weird colors).  It seems the problem is much more mild with oocalc or ooimpress open - mostly just some gray space between open windows in the taskbar becomes black.  In all cases, when I quit OOo things return to normal (I may have to move my mouse over regions of the screen to force them to refresh).

Good luck sorting this out!  It may be an issue w/ kde, OOo, opensuse, nvidia, who knows...
Comment 29 Percy Camilo Triveño Aucahuasi 2008-07-12 02:13:42 UTC
Ok In a debian sid/experimental there is the same bug, I updated my local copy from trunk yesterday. One important thing to note is that the same bug was happening with Firefox2 (Iceweasel 2), but when I updated to Firefox 3 (Iceweasel 3) this "blinks effect" was gone ... any way the bug persists with OO, so maybe ... and just maybe ... it is a bug related with the gtk-KDE integration.

BTW my system:
NVidia GF 7300GS
NVidia driver version: 173.14.09-2 (I think this is the last version)
Kernel : 2.6.25-2-amd64 #1
KDE: Version 4.1.60 (KDE 4.1.60 (KDE 4.2 >= 20080709))
OO version: 2.4.1
Comment 30 Sebastian Sauer 2008-07-12 03:51:46 UTC
@Percy
1) GTK-apps are working fine - try e.g. gedit
2) OO.org and wine don't use GTK
3) since you are on nvidia, comment #22 applies. Welcome to the club :-(
Comment 31 Marco Martin 2008-07-13 20:35:57 UTC
*** Bug 166469 has been marked as a duplicate of this bug. ***
Comment 32 Marco 2008-07-14 10:26:33 UTC
I've got the same bug when I use openoffice-writer and when I write an email with thunderbird (sigh),here my system:

NVidia FX 5200
distro: openSuse 11.0
NVidia driver version: 173.14.09
Kernel : 2.6.25.9-0.2-pae
KDE: 4.0.4 (KDE 4.0.4 >= 20080505) "release 15.1"
OO version: 2.4.0
Comment 33 adibudeen 2008-07-17 06:35:59 UTC
The following workaround seems acceptable (for me anyway).  Use qtconfig (qt3 version) to disable the flashing cursor.  I have no problems after the cursor flashing is disabled.
Comment 34 Marco 2008-07-17 13:23:10 UTC
But this workaround has not effect on openoffice or thunderbird! I've got the same problem.
Comment 35 adibudeen 2008-07-17 14:34:25 UTC
I am using openoffice-kde integration, and it did solve the problem for me.  In Thunderbird, you will probably need to disable the flashing cursor in Gnome control-center.
Comment 36 Marco 2008-07-17 14:40:46 UTC
What is openoffice-kde integration? I can't use Gnome control-center because I'm using kde.
Comment 37 Ronan Arraes Jardim Chagas 2008-07-27 20:51:05 UTC
I can confirm Comment #33.
I'm using openoffice with KDE integration, it is something that is enabled when you compile the package to make openoffice uses KDE look.

When i go to qtconfig (version 3) and disable flashing cursor, this problem stop.

In firefox, i just see the problem when some dialog box is selected and the blinking cursor (which i couldn't disable) is on focus.

My configuration:

Gentoo Linux
Video Card: nVidia 6250
Driver: 173.14.09
Comment 38 Matt Boban 2008-08-03 05:23:25 UTC
The workaround resolved the openoffice issues for me (I never had problems w/ Firefox 3.01). Is there going to be an update to properly resolve this? Why is this report "Invalid"? 
Comment 39 Jason Stubbs 2008-08-03 14:36:41 UTC
*** Bug 168182 has been marked as a duplicate of this bug. ***
Comment 40 Jason Stubbs 2008-08-03 14:38:02 UTC
Reopening as it still seems to be happening and I don't see any comment explaining exactly why the bug was closed...
Comment 41 Ronan Arraes Jardim Chagas 2008-08-03 17:09:30 UTC
I've tested with nvidia drivers 173.14.12 and the problem continues...
Comment 42 Swaroop Shankar 2008-08-03 18:52:37 UTC
I think this kind of behavior is when an edit area is opened in GTK application. Why I said this is because in eclipse when no file to edit is opened such an issue is not found. Its only found when some file is opened for editing. Could someone confirm on this? 
Comment 43 Aaron J. Seigo 2008-08-03 22:03:49 UTC
> I don't see any comment explaining exactly why the bug was closed

the comments about "this is a driver problem" were the explanation.
Comment 44 Ronan Arraes Jardim Chagas 2008-08-04 06:07:48 UTC
Now i can confirm: i've installed firefox 3 and now i can disable the flashing cursor. After that all the problems was gone, with firefox and with openoffice. When i enable flashing cursor again, the problems come back.

I'm using KDE 4.1 with nVidia drivers 173.14.12.
Comment 45 Valentin Iliev 2008-08-13 09:20:20 UTC
Hi, same problem with Openoffice 2.4.1 and KDE 4.1 - corruption of plasma widgets. I'm with Nvidia 7300GT, PIV 3.0GHz, Mandriva 2008.1 and latest kernel . Disabling of blinking cursor in qtconfig dont resolve problem for me. Problem exist with or without using of Compiz - this mean is not related to Compiz for me.
Comment 46 Matt Boban 2008-08-14 19:04:09 UTC
>this mean is not related to Compiz for me. 


Well, yes. The problem is most likely within the proprietary drivers Nvidia still has not fixed. 
Comment 47 Bastien Jansen 2008-10-16 22:24:02 UTC
Hi, I'm using KDE 4.1.2 with Nvidia drivers (version 169.12) on x64. I still get the problem after having installed openoffice.org-kde and disabled the flashing cursor with both qtconfig-qt3 and qtconfig-qt4...

Is there womething I missed?
Comment 48 Ronan Arraes Jardim Chagas 2008-10-26 16:07:57 UTC
Same problem with OpenOffice 3.0 and nVidia drivers 170.80.
Comment 49 Ronan Arraes Jardim Chagas 2008-10-27 00:35:01 UTC
This is the way that I avoid this problem:

1) For firefox, I have disabled in gnome keyboard preferences the blinking cursor.

2) For openoffice, I have compiled with KDE integration (it uses kdelibs 3.5.10 in my case) and than I have also disabled the blinking cursor in qtconfig version 3 (in gentoo, it is located at /usr/qt/3/bin/qtconfig).

After that, I have never had any problems related with this bug.
Comment 50 George Kiagiadakis 2008-11-03 13:19:32 UTC
*** Bug 174164 has been marked as a duplicate of this bug. ***
Comment 51 George Kiagiadakis 2008-11-03 13:22:56 UTC
*** Bug 174155 has been marked as a duplicate of this bug. ***
Comment 52 Valentin Iliev 2008-11-09 18:39:30 UTC
So, I'm with Mandriva 2009 now and KDE 4.1.2 and can confirm that bug is still exist. Unfortunately I cant stop flashing cursor in OpenOffice 3.0. I try qtconfig in /usr/lib/qt3/bin/qtconfig and also in /usr/lib/qt4/bin/qtconfig (both QT3 and QT4) but after saving of configuration cursor still flash in OpenOffice 3.0 and of course all plasma widgets are going crazy. Please if someone know how to disable flashing cursor I will be very happy to receive hints about it.
Regards,
Valentin
Comment 53 Dimitrios Glentadakis 2008-11-14 21:42:23 UTC
me too , i cannot fix it with the qtconfig
mandriva 2009 kde 4.1.2
http://img514.imageshack.us/img514/6033/ooplgj2.jpg
the probleme is very important, i have not alternative solution than openoffice , mandriva doesnt have packages for koffice. How can i work with it ?
please fix it as soon as possible

thank you 
Dimitri

Comment 54 Ian Smith 2008-12-06 11:12:34 UTC
The problem is as bad as ever, using either the latest NVIDIA 1.77.82 driver or the FOSS Nouveau driver.

That is with KDE4.2 Beta sitting on OpenSuse 11.0

I do realise that this is a driver problem, but, since neither NVIDIA nor Nouveau seem to be able to solve it, what is the future for those of us with these cards. Are we to be excluded from the KDE4 party unless we change over to ATI?
Comment 55 Ian Smith 2008-12-06 14:29:16 UTC
Good news! 

For any fellow long-suffering NVIDIA card users, the new 180.11 beta driver seems finally to have solved the problem - for my system at least.

Good luck with yours, and lets hope this driver moves into repositories asap.
Comment 56 adibudeen 2008-12-06 15:43:04 UTC
After testing, I can confirm this.  I tried the 180.06 beta driver on my GeForce 6600, and the problem appears to be gone, even with qtconfig blinking cursor set to very high speeds.
Comment 57 Jonathan Thomas 2008-12-11 17:58:59 UTC
*** Bug 173592 has been marked as a duplicate of this bug. ***
Comment 58 Ralph Moenchmeyer 2008-12-11 20:35:16 UTC
I tested with my Nvidia 7800 GTX,  180.6 beta driver, KDE 4.2 (unstable repository from SuSE)   , Opensuse 11.0 and several GTK dependent applications - including Openoffice, Firefox and VMware workstation 6 (especially with the latter the artefacts on the taskbars appeared in large scale and very frequently) .

All the artefacts seem to be gone with the new beta driver. In addition previous severe problems of Konqueror with displaying transparent or semi-opaque objects (e.g. DIVs) on web pages have disappeared completely.  
 
Comment 59 Gustavo A. Díaz 2008-12-11 23:38:00 UTC
Resolved? where?
Yeah... resolved for those who have GeForce cards greater than 6000/7000 which is what the beta drivers supports... What about those who have 5000 series¿? I have a Linux Centre full of those cards in 11 workstations... so, what i should do? Use Gnome instead?....

This is not resolved... I posted this problem in Nvidia as well too. Cause those series cards are still far enough usable.... and is stupid just buy new cards (cause i have not the money to do so, and plus still those card works great) cause of this ugly bug.
Comment 60 Mary Ellen Foster 2008-12-12 09:50:31 UTC
Well, there is another option for those of us (I'm another) with 5000-series cards -- after all, most of the time, there's no *need* to use the proprietary nvidia drivers. I've disabled desktop effects and gone back to the "nv" drivers instead, so I've now got an artefact-free (if also eyecandy-free) desktop.
Comment 61 Gustavo A. Díaz 2008-12-12 12:21:22 UTC
Well, yes if you want to disable desktop effects yes... I guess i must wait to nouveau driver... Since there is no response from nvidia devs either.
Comment 62 Sebastian Turzański 2008-12-21 00:31:30 UTC
still a problem in opensuse 11.1 with kde4beta2 and nvidia fx6200
Comment 63 Ian Smith 2008-12-21 02:45:04 UTC
Sebastian

I also updated to 11.1, but the default driver (assuming you have subscribed to the nvidia repository) still has 170 series drivers. After all, 180 drivers are still beta - though they seem to work OK.

If you want to install the beta driver, you can download it from: http://download.nvidia.com/XFree86/Linux-x86/1.0-9625/NVIDIA-Linux-x86-1.0-9625-pkg1.run

Instructions for installing it are at: http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html#2

Hope this helps
Comment 64 Dimitrios Glentadakis 2009-01-13 22:16:41 UTC
I ve just installed this driver :
x11-driver-video-nvidia-current-180.22-1mdv2009.0

and i dont have any more the problem !

Mandriva 2009.0 
KDE 4.1.3 
kernel-desktop-2.6.27.7-1mnb-1-1mnb2



Comment 65 Sebastian Turzański 2009-01-13 22:19:55 UTC
I confirm that with thi new nvidia 180.22 driver it works ok 
opensuse 11.0
Comment 66 Jonathan Thomas 2009-01-18 20:23:28 UTC
*** Bug 181193 has been marked as a duplicate of this bug. ***
Comment 67 John Tweed 2009-02-11 21:07:34 UTC
Using OpenSuse 11.1 (x86_64) KDE 4.1.3 "release 4.9". Have updated to the 180.22 nvidia driver from the repository and it has removed the strange graphics behaviour when OOo is in focus. Great!
Comment 68 Ralph Moenchmeyer 2009-02-13 16:01:30 UTC
Driver 180.22 also works well for Opensuse 11.1 (x86_64), KDE 4.2 (from Opensuse "Factory" repository mixed with some rpms from the KDE 4 "Unstable" repository). No artefacts for GTK based applications anymore.    
Comment 69 Jonathan Thomas 2009-03-11 13:45:11 UTC
*** Bug 186848 has been marked as a duplicate of this bug. ***