Bug 156636 - Missing keyboard shortcuts for accessing to a specified tab number
Summary: Missing keyboard shortcuts for accessing to a specified tab number
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0
Platform: Gentoo Packages Linux
: NOR wishlist with 86 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 166476 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-25 10:59 UTC by Philippe Gassmann
Modified: 2020-07-04 10:19 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Gassmann 2008-01-25 10:59:53 UTC
Version:           2.0 (using KDE 4.0.0)
Installed from:    Gentoo Packages
OS:                Linux

Previous version of konsole had this wonderful kick-ass feature : 
 - you define a keyboard shortcut for TAB number 1, 2, 3, 4...
 - then you can use this shortcut to quickly access to the tab without navingating through all tabs and without using the mouse.
Comment 1 Victor Trac 2008-02-26 13:43:59 UTC
I miss having this option as well from KDE3/Konsole1.6.x.  
Comment 2 Robert Knight 2008-07-22 00:08:33 UTC
*** Bug 166476 has been marked as a duplicate of this bug. ***
Comment 3 Robert Knight 2008-07-25 17:05:19 UTC
SVN commit 837725 by knight:

Add keyboard actions for switching to the Nth tab
(where N is from 1 to 10)

Shortcuts must be assigned via Settings -> Configure Shortcuts to use.

BUG:156636


 M  +23 -1     ViewManager.cpp  
 M  +3 -0      ViewManager.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=837725
Comment 4 Sebastian Vahl 2008-09-13 23:28:30 UTC
This seems no to be present in KDE 4.1.1. Is there a plan when this options will be available?
Comment 5 Robert Knight 2008-09-14 22:41:33 UTC
This will be available in KDE 4.2.  Unfortunately I couldn't add them to KDE 4.1.1 because this change required new text in the user interface which has to be translated.