Bug 156574 - moving the mouse outside of a textarea de-selects the text in it
Summary: moving the mouse outside of a textarea de-selects the text in it
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml forms (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-24 18:14 UTC by S. Burmeister
Modified: 2011-05-14 19:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2008-01-24 18:14:55 UTC
Version:            (using KDE 4.0.0)
OS:                Linux

If one has a textarea, like the one on b.k.o and several lines of text, i.e. more than can be displayed at once in the textarea, and starts to select the text at the end and then moves up the mouse to the beginning, one has to leave the textarea to make the text scroll-up and get to the first line and letter.

Yet as soon as the mouse-cursor leaves the textarea, e.g. at the top or side, the selection and scrollbar starts jumping up and down.

Expected behaviour would be to keep the selection and scroll up line by line, selecting everything until the first line/letter is reached.
Comment 1 FiNeX 2008-01-26 10:25:35 UTC
Woah... just tried on revision 764637.
The selection is crazy... It looks funny :-) :-)


Bug confirmed :-(
Comment 2 missive 2008-08-09 02:52:38 UTC
It is not just if the textarea has enough text to require scrolling.

Even in a partially filled textarea, text selection is broken.

Try starting in the middle of the textarea and selecting all of the text from that point to the beginning of the text.

You have to hit the beginning of the text almost exactly. If you happen to overshoot and go outside of the textarea, the selection either disappears (if you selected from the very end) or switches to selecting to the end instead of to the beginning.
Comment 3 Robert Kratky 2009-08-21 18:55:10 UTC
Konqueror 4.3.0, Qt 4.5.2., Debian Sid

Still the same in KDE 4.3.0.
Comment 4 Germain Garand 2010-02-13 18:04:28 UTC
SVN commit 1089664 by ggarand:

mitigate textarea selection extension problem by clamping
the mouse move event to the widget rect, so that the
selection isn't reset when you leave the widget rect while selecting.

at least you can now extend+scroll from top to bottom (selecting
from bottom to top still doesn't scroll properly though.)

possible turnaround would be to send a mousewheel event in the appropriate
direction when the mouse event is outside the rect..

CCBUG: 156574

 M  +16 -0     render_replaced.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1089664
Comment 5 FiNeX 2010-09-07 21:49:17 UTC
Cannot reproduce using KDE 4.4.5.
Comment 6 missive 2010-09-07 22:39:19 UTC
It's not completely fixed.

Generally, in a textarea that has enough text for a scrollbar, starting a selection and moving the mouse outside of the textarea will cause the area to scroll and extend the selection.

Maybe that should be a separate bug report?
Comment 7 FiNeX 2010-09-07 23:14:44 UTC
@Massive: it should be correct to report it as a wish. Thanks
Comment 8 FiNeX 2010-09-07 23:15:16 UTC
@Missive: if you will open it, please add me on the CC list. Thanks :-)
Comment 9 missive 2011-05-14 19:24:31 UTC
Added Bug 273282 for the last bit of trouble with selecting text in a textarea.