Bug 156099 - Make find and find/replace in Kate search all open files
Summary: Make find and find/replace in Kate search all open files
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 67 votes (vote)
Target Milestone: ---
Assignee: Kåre Särs
URL:
Keywords:
: 173350 193470 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-18 13:59 UTC by Ben Munro
Modified: 2011-11-13 10:35 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Munro 2008-01-18 13:59:43 UTC
Version:           3.0.80 (using Devel)
Installed from:    Compiled sources
Compiler:          g++ 4.1.2-16ubuntu2 
OS:                Linux

It would be great if Kate could search for strings in all open files, rather than just the document currently being viewed

This is the same feature request as #63417, but I don't think that was resolved properly, and it isn't available in the latest version of Kate anyway.

Apart from that, keep up the good work guys!
Comment 1 Michiel Helvensteijn 2008-08-02 16:39:18 UTC
There is already a "Find in files" plugin available, which does something similar. However, there is no easy way to do a find/replace over all (open) files.
Comment 2 Aardwolf 2008-10-05 13:03:06 UTC
In response to

"There is already a "Find in files" plugin available, which does something similar. However, there is no easy way to do a find/replace over all (open) files.":

The "Find in Files" feature of Kate doesn't seem to have any connection with the documents you have open in it. It searches in directories instead. There's nothing you can do with it that you can't already do in the terminal.

Having the ability in Kate to do search, and search and replace, in all open documents (independent of directories or non opened documents) in one go, would definitely be a very useful feature, that is currently not in it! My vote goes to: implement it :)

For the find in open files: either, the results could be given in a list (similar to visual studio), or it could just behave like regular search except when the end of one document is reached, it goes to the next, and so on.
Comment 3 FiNeX 2009-05-23 15:09:38 UTC
*** Bug 173350 has been marked as a duplicate of this bug. ***
Comment 4 FiNeX 2009-05-23 15:09:52 UTC
*** Bug 193470 has been marked as a duplicate of this bug. ***
Comment 5 FiNeX 2009-05-23 15:10:29 UTC
I'd like this feature too :-)
Comment 6 Dominik Haumann 2011-08-12 09:35:34 UTC
The new search plugin supports searching in all opened files (or on disk).
So this report is fixed to 50%. Replace will come at some point ;)
Comment 7 Technologov 2011-11-13 07:09:53 UTC
+1 on this feature.

-Technologov
Comment 8 Kåre Särs 2011-11-13 10:31:10 UTC
This is fixed and will be part of KDE 4.8
Comment 9 Kåre Särs 2011-11-13 10:35:24 UTC
PS. it is fixed in the "Search and Replace" plugin :)