Bug 155741 - Refuses to load .oga (OGG Audio) files
Summary: Refuses to load .oga (OGG Audio) files
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.8
Platform: Debian testing Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-14 13:02 UTC by Thorben
Modified: 2009-01-28 01:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorben 2008-01-14 13:02:03 UTC
Version:           1.4.8 (using KDE KDE 3.5.8)
Installed from:    Debian testing/unstable Packages
OS:                Linux

It is becoming common to give audio ogg files the extension .oga so that you can tell them apart from video ogg files and such.
OGG encoding tools even recommend this naming scheme (see man flac).

However amarok refuses to load such files saying that they are unsupported (untrue).
This seems like another instance of relying on file names and not mime type (eg bug 126511).

Quickest fix is adding oga (and ogv, etc) as synonyms for ogg.
Comment 1 Thorben 2008-01-14 13:45:28 UTC
Please see this page for more details on OGG file extensions and mime types:
http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions
Comment 2 Ian Monroe 2008-01-14 16:46:32 UTC
Why can't Xiph make up their minds? :/

I suppose I'm glad they finally recognized the need for differentiating between audio and video files though.

However I'm somewhat tempted to just wait for xine-lib to add support for this file extension since the link you gave is to a RFC and I didn't see anything about suggested filename extensions in my `man flac`.
Comment 3 Thorben 2008-01-14 17:24:24 UTC
Hope this helps...

NAME
       flac - Free Lossless Audio Codec

SYNOPSIS
       flac [ OPTIONS ] [ infile.wav | infile.aiff | infile.raw | infile.flac | infile.oga

.........snip....

     --ogg  When  encoding, generate Ogg FLAC output instead of native FLAC.  Ogg FLAC streams are FLAC streams wrapped in an Ogg
              transport layer.  The resulting file should have an ’.oga’ extension and will still be decodable by flac.


flac 1.2.1
Comment 4 Mark Kretschmann 2008-01-14 19:19:35 UTC
Yeah but what's the deal? Amarok doesn't know anything about file extensions. We ask xine-lib what extensions it supports and then xine says OK or NOPE.
Comment 5 Thorben 2008-01-15 16:20:00 UTC
OK. So a bug needs filling with xine?
Thank you.
Comment 6 Dan Meltzer 2008-01-15 20:43:25 UTC
SVN commit 761962 by dmeltzer:

Add support for "oga" files in places where we can (That I can find).
I've left the media devices alone as some may not handle .oga properly, and users can always add the file format themselves if they so choose.
This still needs to be backported to stable, I don't have a checkout.
CCBUG: 155741


 M  +1 -1      src/editfilterdialog.cpp  
 M  +1 -0      src/filebrowser/mydirlister.cpp  
 M  +1 -1      supplementary_scripts/nowplaying/amaroknowplaying.rb  


WebSVN link: http://websvn.kde.org/?view=rev&revision=761962
Comment 7 Thorben 2008-01-15 22:00:59 UTC
Hi Dan,

In trunk/extragear/multimedia/amarok/supplementary_scripts/nowplaying/amaroknowplaying.rb

You added .ogg a second time, and not .oga =)

http://websvn.kde.org/trunk/extragear/multimedia/amarok/supplementary_scripts/nowplaying/amaroknowplaying.rb?r1=761962&r2=761961&pathrev=761962

Should this bug still be unconfirmed? even if there is thought that it needs to be pushed to libxine.
Comment 8 Dan Meltzer 2008-01-16 05:19:41 UTC
Just fixed.

I think that this should be resolved as fixed as soon as it gets backported to the stable branch.  We will have fixed all we can do.
Comment 9 Harald Sitter 2008-03-16 01:49:22 UTC
NOMINATE FOR 1.4.9
Comment 10 Dan Meltzer 2009-01-28 01:45:21 UTC
Heh, we're so not backporting this now :p

RESO:FIXEDAFOREVERAGO