Bug 154582 - switching language results in several highscore lists
Summary: switching language results in several highscore lists
Status: RESOLVED FIXED
Alias: None
Product: libkdegames
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Matt Williams
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-24 22:54 UTC by Jakob Sack
Modified: 2008-05-01 18:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Sack 2007-12-24 22:54:11 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

I'm using kde4daily. Until yesterday I used it in English. Today I installed the German language pack. After winning a game in knetwalk the highscore list contained two tabs called "einfach" (easy). I guess (not knowing any code) that the list exists as "easy" and "einfach". Note that the lists are completely different. So I have the old "English" one and the new "German" one. Winning a game adds an entry to the new one.
Gonna post a screenshot if needed.
Comment 1 Matt Williams 2008-04-27 17:28:27 UTC
Hi Jakob. Can you still reproduce this bug? If you can reproduce it or if you still have the knetwalkrc file (most likely in ~/kde4/share/config) from before could you post it here?
Comment 2 Matt Williams 2008-04-27 18:34:01 UTC
Jakob, Never mind. I can now produce this bug. It's caused by KGameDifficulty passing a pretranslated string to KScoreDialog which confuses things.
Comment 3 Matt Williams 2008-05-01 18:43:36 UTC
SVN commit 803022 by milliams:

Fix the mess that was i18n in KScoreDialog. Scores are now indexed by a key and translations for each key are added explicitly.
Patch KSquares, KMines, KNetwalk and Kollision to use this correctly.

BUG: 151415
BUG: 153811
BUG: 154582
BUG: 156870

CCMAIL: kde-games-devel@kde.org

 M  +5 -4      kmines/mainwindow.cpp  
 M  +4 -2      knetwalk/src/mainwindow.cpp  
 M  +4 -2      kollision/mainwindow.cpp  
 M  +6 -2      ksquares/src/ksquareswindow.cpp  
 M  +98 -43    libkdegames/highscore/kscoredialog.cpp  
 M  +41 -3     libkdegames/highscore/kscoredialog.h  
 M  +41 -13    libkdegames/kgamedifficulty.cpp  
 M  +12 -0     libkdegames/kgamedifficulty.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=803022