Bug 154512 - Add widgets close button appears after manual paint
Summary: Add widgets close button appears after manual paint
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-23 09:06 UTC by Maciej Pilichowski
Modified: 2007-12-27 16:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2007-12-23 09:06:22 UTC
Version:            (using KDE KDE 3.97.0)

CPU 2GHz and I have to wait several seconds to add a widget, is dead slow.Please, show at least "x" mark right away, as a small feedback that user actually added something.
Comment 1 Jason Stubbs 2007-12-23 11:20:45 UTC
"It's slow" bugs are not being accepted, but there is an issue that applets starting or closing don't cause an update(). In other words, the button doesn't appear or disappear until the mouse enters the listview.
Comment 2 Maciej Pilichowski 2007-12-23 13:22:48 UTC
Jason -- I rephrase then. There is no visual feedback at all, not even busy cursor mouse and I have to wait several seconds. So I have no clue if I really added the widget and I have to wait, or I didn't and I have to add it again.
Comment 3 Jason Stubbs 2007-12-23 13:52:07 UTC
How are you running kde4?
Comment 4 Maciej Pilichowski 2007-12-23 14:52:41 UTC
KDE4LiveRC2+. Via VirtualBox or booting from CD (since I see no difference I am testing it now with VB).
Comment 5 Jason Stubbs 2007-12-23 15:12:35 UTC
That's where the slowness is coming from. VirtualBox has virtualization overhead and running off CD has poor seek times. In both cases, the file system is being decompressed on the fly. Applets appear instantaneously with a regular installation.
Comment 6 Maciej Pilichowski 2007-12-23 15:43:58 UTC
Slowness of the system can be achieved as well by simply running KDE4 on slow CPU. So visual feedback (busy cursor mouse) would be very welcome. Users of older computer will be grateful (me including, I still use PIII 800MHz running KDE 3.5.8 now).

Comment 7 Jason Stubbs 2007-12-24 03:18:08 UTC
*** Bug 154549 has been marked as a duplicate of this bug. ***
Comment 8 Jason Stubbs 2007-12-24 05:09:55 UTC
setData() is being called normally and is not being overridden anywhere that I can see so the dataChanged() signal should be going though fine. Not sure why it's not... Need somebody strong on interview for this one.
Comment 9 Aaron J. Seigo 2007-12-27 15:20:39 UTC
before the widget is ready we don't know where it will appear. i don't see a way to address this with a poor hack. this make this BR a "make it faster" report which isn't useful as it's a general and never fully achievable BR (optimizations can always be done, right?)
Comment 10 Maciej Pilichowski 2007-12-27 15:29:37 UTC
This report gone somewhere else I didn't intended, it was added another my report (now 100% valid), and not it is a wontfix.

So back to visual feedback --> please change cursor to mouse busy cursor (reopening).
Comment 11 Jason Stubbs 2007-12-27 15:37:19 UTC
Bug 154549 is exactly what i was talking about in my first comment, which is why I marked it as a dupe of this. But the other one is cleaner so it's better to leave that one open instead.

As for visual feedback, the mouse pointer should show a plus next to it up until the time that the plasmoid is loading. The plasmoid becomes visible straight after that. There isn't actually any time to show a busy cursor.
Comment 12 Maciej Pilichowski 2007-12-27 15:47:29 UTC
1) user clicks "add"
2) change the mouse cursor
3) load and run widget 
4) change the mouse cursor back

Am I missing something?
Comment 13 Jason Stubbs 2007-12-27 16:02:12 UTC
That can be done.
Comment 14 Jason Stubbs 2007-12-27 16:04:14 UTC
SVN commit 753469 by jstubbs:

Switch to a busy cursor while the applet is loading

BUG: 154512


 M  +10 -0     containment.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=753469
Comment 15 Maciej Pilichowski 2007-12-27 16:08:33 UTC
Jason, thank you!