Bug 154241 - Attachment icon never shown for IMAP accounts
Summary: Attachment icon never shown for IMAP accounts
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.51
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 123704 154496 166525 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-17 18:23 UTC by Thorsten Staerk
Modified: 2008-08-12 15:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
incomplete patch to show a development direction (1001 bytes, patch)
2007-12-18 02:27 UTC, Thorsten Staerk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Staerk 2007-12-17 18:23:18 UTC
Version:           1.9.8 (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

In kmail, there is a column "attachment" that shows pixAttachment in case the respective mail has an attachment. But for imap accounts this is not true, the column always shows blank here.
Comment 1 Thomas McGuire 2007-12-18 00:17:34 UTC
Is this a duplicate of bug 123704?
Comment 2 Thorsten Staerk 2007-12-18 00:47:04 UTC
*** Bug 123704 has been marked as a duplicate of this bug. ***
Comment 3 Thorsten Staerk 2007-12-18 02:27:42 UTC
Created attachment 22605 [details]
incomplete patch to show a development direction
Comment 4 Thorsten Staerk 2007-12-18 12:55:14 UTC
When this bug occurred, I had an imap account A.
Now that I have an imap account A and an imap account B, the error only occurs in imap account B, imap account A is fine.

I deleted imap account B, and now, the error again occurs in account A.
Comment 5 Thorsten Staerk 2007-12-18 13:08:41 UTC
Researching more, I find that the attachment-icon is only shown for mails that have another icon that is for pitty not explained with a whatsthis-help or so.
Comment 6 Thorsten Staerk 2007-12-18 13:11:33 UTC
Ok, looking in kmail/pics: Only mails that have the kmmsgsent.png icon get a pixAttachment icon. Mails that have the kmmsgread.png icon do not get a pixAttachment icon even if they contain an attachment.
Comment 7 Thorsten Staerk 2007-12-18 13:43:34 UTC
Starting from the beginning: With my kmail imap account I can receive messages with an attachment. These are marked with the icon pixAttachment. But when I send a message with attachment myself, only the sent message (to be recognized by the kmmsgsent.png icon) carries the icon pixAttachment, the received message (to be recognized by the kmmsgread.png icon) does not carry the icon pixAttachment.

In other words, if other people send me attachments, kmail recognizes this, but if I receive a mail from me with attachment, kmail does not recognize.
Comment 8 Thomas McGuire 2007-12-22 22:19:56 UTC
*** Bug 154496 has been marked as a duplicate of this bug. ***
Comment 9 Thorsten Staerk 2008-01-08 06:41:09 UTC
Today I sent myself a message with 125.4 KB and the icon was shown in the inbox and in "sent-mail". So, size matters ;)
Comment 10 Marc Pignat 2008-04-15 17:39:18 UTC
I think I have the same problem, but it is not related to imap.
I can observe thee same behavior when the message is copied to a local folder, the icon is still not displayed.

here is a test message not displaying the attachment icon : http://lkml.org/lkml/2008/4/13/302 then click on forward.

This message has an attachement (a patch) and the icon is not displayed, neither in my imap inbox nor after beeing copied to a local folder.

kmail 1.9.9/KDE 3.58 on Linux debian/testing

Best regards

Marc
Comment 11 Ferdinand Gassauer 2008-05-29 15:41:15 UTC
problem still in 1.9.51 kde 4.1 beta 1

with "load attachment on demand" is TRUE

after clicking the message the icon is shown 
Comment 12 Thomas McGuire 2008-07-14 17:17:00 UTC
*** Bug 166525 has been marked as a duplicate of this bug. ***
Comment 13 Thorsten Staerk 2008-08-12 15:36:12 UTC
I could verify this is fixed with KDE 4.1 revision 844716.