Bug 153493 - Wrong displaying of new folder icons
Summary: Wrong displaying of new folder icons
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-05 17:40 UTC by Oliver Becker
Modified: 2008-01-16 20:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Becker 2007-12-05 17:40:33 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc version 4.1.1 (Gentoo 4.1.1-r3) 
OS:                Linux

If you want to select an different icon for any folder, the .directory entry of this folder (and so dolphin) will only use the 48x48 version of this icon, because this size is used in the preview dialog. It should only use the name of the icon instead of name and size, so that dolphin can choose the size itself.
Comment 1 FiNeX 2007-12-20 17:26:09 UTC
I confirm this. The icon is resized and it looks very ugly!
Comment 2 Gabriel Trisca 2007-12-24 12:38:18 UTC
I have the same problem with dolphin SVN.

This is a duplicate of bug 153493

http://bugs.kde.org/show_bug.cgi?id=153493
Comment 3 Peter Penz 2008-01-16 20:29:09 UTC
SVN commit 762301 by ppenz:

Fixed issue that inside the .directory file the full path of an icon is given:
  Icon=/home/jakob/dev/kde/install/kde/share/icons/oxygen/48x48/places/user-desktop.png
instead of
  Icon=user-desktop

The full path leads to a blurry icon when showing the icon in an increased size (e. g. in the Dolphin information bar).

BUG: 153493


 M  +17 -17    kicondialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=762301