Bug 153421 - "open with" dialog obscures every dolphin window opened
Summary: "open with" dialog obscures every dolphin window opened
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-04 14:12 UTC by Fede
Modified: 2014-02-12 09:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fede 2007-12-04 14:12:16 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          g++ 4.13 
OS:                Linux

clicking on an unknown file (i tried with a backup file) open the dialog "open with". This obscures the current dolphin window,  but also all the other dolphin windows i've opened. 

this makes all the dolphin instances unusable till i choose an option in the open with dialog...

i'm not sure it's just a dolphin behaviour, but i found this only here.
Comment 1 FiNeX 2007-12-20 17:24:30 UTC
I can confirm this.
Comment 2 Peter Penz 2008-01-10 18:05:52 UTC
I've changed the product to kdelibs, as in KRun::displayOpenWithDialog() from kdelibs/kio/kio/krun.cpp the KOpenWithDialog is opened modal. @David: is it OK for you if I fix this?
Comment 3 David Faure 2008-01-10 21:50:08 UTC
Funny it was never considered a problem in KDE 3 :-)

If it's not modal anymore, then one problem will be that the user can get multiple dialogs if clicking multiple times on a given file.

Apart from that, no objections (you'll need a private QObject hidden in krun.cpp for the slot...).

David.
Comment 4 Peter Penz 2008-01-10 21:59:09 UTC
> Funny it was never considered a problem in KDE 3 :-)

Interesting :-)

> If it's not modal anymore, then one problem will be that
> the user can get multiple dialogs if clicking multiple
> times on a given file.

Ah, good input. I know some users still double clicking on files for starting the application, although single click is activated.

> Apart from that, no objections (you'll need a private
> QObject hidden in krun.cpp for the slot...).

Thanks for the hint. I'll wait with the implementation until KDE 4.0 is out some weeks for (hopefully) getting further user input...
Comment 5 Dario Andres 2009-04-03 00:38:53 UTC
(Just updating) Still valid here using:

Qt: 4.5.0 + qt-copy-patches-936035
KDE: 4.2.68 (KDE 4.2.68 (KDE 4.3 >= 20090327))
kdelibs svn rev. 946159 / kdebase svn rev. 946160
on ArchLinux i686 - Kernel 2.6.28.8
Comment 6 Dawit Alemayehu 2013-12-15 13:23:35 UTC
This is no longer the case since Dolphin is not a single instance application anymore. However, this affects Konqueror when one opens new window from existing one and attempts and clicks on unknown file.
Comment 7 Dawit Alemayehu 2013-12-22 13:29:19 UTC
Git commit f44119a6271aeb142de83753a02ec5cef0bf4ac8 by Dawit Alemayehu.
Committed on 15/12/2013 at 13:21.
Pushed by adawit into branch 'KDE/4.12'.

Changed OpenWith dialog from Qt::ApplicationModal to Qt::WindowModal.
REVIEW: 114473
FIXED-IN: 4.12.1

M  +1    -0    kio/kio/krun.cpp

http://commits.kde.org/kdelibs/f44119a6271aeb142de83753a02ec5cef0bf4ac8
Comment 8 Dawit Alemayehu 2014-02-12 09:43:12 UTC
Git commit 6d99b077800b62c68370a1e916a64ffcbc2bb73d by Dawit Alemayehu.
Committed on 25/12/2013 at 14:35.
Pushed by adawit into branch 'master'.

Changed OpenWith dialog from Qt::ApplicationModal to Qt::WindowModal.
REVIEW: 114473
FIXED-IN: 4.12.1

M  +1    -0    src/widgets/krun.cpp

http://commits.kde.org/kio/6d99b077800b62c68370a1e916a64ffcbc2bb73d