Bug 153346 - Main splitter size set to zero
Summary: Main splitter size set to zero
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-03 14:19 UTC by Tobias Powalowski
Modified: 2007-12-06 21:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Powalowski 2007-12-03 14:19:33 UTC
Version:           3.96.2 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.2 
OS:                Linux

After changing the view mode in settings from long folder list to short folder list the mail list is gone forever. Only starting with empty kmailrc brings it back.
Comment 1 Thomas McGuire 2007-12-03 19:34:57 UTC
Right, I can confirm it. Only happens when the favorite folder view is toggled as well.
The size of the main splitter is set to 0.
Comment 2 Thomas McGuire 2007-12-06 21:50:54 UTC
SVN commit 745697 by tmcguire:

Rewrite the layout code of the main widget.
The splitter layout has many interesting special cases, which
were all spread around in the code. Now it is all in layoutSplitters().
Now widgets shouldn't be hidden anymore because the splitter sizes
were zero after changing the layout. This needed some more config keys.

Cleaned up readConfig a bit, and other places as well.
Plus some style fixes.

BUG: 153346



 M  +12 -1     kmail.kcfg  
 M  +392 -336  kmmainwidget.cpp  
 M  +14 -20    kmmainwidget.h  
 M  +2 -4      kmreaderwin.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=745697