Bug 151415 - High score dialog are showing unknown characters for Chinese characters
Summary: High score dialog are showing unknown characters for Chinese characters
Status: RESOLVED FIXED
Alias: None
Product: libkdegames
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Matt Williams
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-27 09:32 UTC by Funda Wang
Modified: 2008-05-01 18:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
knetwalk-highscore.png (30.09 KB, image/png)
2007-10-27 09:45 UTC, Funda Wang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Funda Wang 2007-10-27 09:32:51 UTC
Version:           3.4.91 (using KDE KDE 3.94.0)
Installed from:    Mandriva RPMs

The vertical heading(?) shows strange characters in zh_CN locale

screenshot says all.
Comment 1 Funda Wang 2007-10-27 09:45:17 UTC
Created attachment 21919 [details]
knetwalk-highscore.png
Comment 2 Funda Wang 2007-12-13 23:13:55 UTC
still valid in 3.97.1

In fact, when the high score dialog was firstly shown for me to input my name, the level looks correct, but when it shows again if I click high score from toolbar, it becomes unknown characters again. So, there must be something wrong when saving the level name and the user name.
Comment 3 Matt Williams 2008-04-27 17:44:18 UTC
This works fine for me. I tried with both ja and zh_CN locales. If you are still experiencing this bug please post a message here and I'll look into it further.
Comment 4 Matt Williams 2008-04-27 18:28:17 UTC
No, I take this back. It seems that this is a knetwalk specific bug caused by using kscoredialog incorrectly.
Comment 5 Matt Williams 2008-04-27 18:29:58 UTC
Reopen
Comment 6 Matt Williams 2008-05-01 18:43:35 UTC
SVN commit 803022 by milliams:

Fix the mess that was i18n in KScoreDialog. Scores are now indexed by a key and translations for each key are added explicitly.
Patch KSquares, KMines, KNetwalk and Kollision to use this correctly.

BUG: 151415
BUG: 153811
BUG: 154582
BUG: 156870

CCMAIL: kde-games-devel@kde.org

 M  +5 -4      kmines/mainwindow.cpp  
 M  +4 -2      knetwalk/src/mainwindow.cpp  
 M  +4 -2      kollision/mainwindow.cpp  
 M  +6 -2      ksquares/src/ksquareswindow.cpp  
 M  +98 -43    libkdegames/highscore/kscoredialog.cpp  
 M  +41 -3     libkdegames/highscore/kscoredialog.h  
 M  +41 -13    libkdegames/kgamedifficulty.cpp  
 M  +12 -0     libkdegames/kgamedifficulty.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=803022