Bug 151205 - Okular's sidebar takes too much space in x direction
Summary: Okular's sidebar takes too much space in x direction
Status: RESOLVED WORKSFORME
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 159253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-23 00:45 UTC by Roland Leißa
Modified: 2008-11-08 14:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Leißa 2007-10-23 00:45:28 UTC
Version:            (using KDE KDE 3.94.0)
Installed from:    Gentoo Packages
OS:                Linux

IMHO the sidebar takes too much space in x direction as you cann see here:
http://liquidat.files.wordpress.com/2007/10/okular.png
I know that this was done because of usability which can be read here:
http://www.kdedevelopers.org/node/2922
But why isn't it done like Kate's or Konqueror's sidebar?
It just takes a bit of space in x direction and clicking again on the same field collapes this view. Furthermore imagine other languages where perhaps "Thumbnails" must be translated into two words each containing 10 characters or so.

Implementing this would be really great.
Comment 1 Pino Toscano 2007-10-23 00:47:31 UTC
Like right click on the sidebar -> [ ] Show text ?
Comment 2 Pino Toscano 2007-10-23 00:54:37 UTC
Forgot to say: the setting there is remembered; it's planned the possibility to configure the size of the icons.
Comment 3 Pino Toscano 2007-11-01 23:58:13 UTC
SVN commit 731824 by pino:

Make it possible to choose the size for the icons in the sidebar, by choosing it in the popup menu of the sidebar itself.

CCBUG: 151205


 M  +3 -0      conf/okular.kcfg  
 M  +30 -1     ui/sidebar.cpp  
 M  +1 -0      ui/sidebar.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=731824
Comment 4 Pino Toscano 2007-11-02 00:16:35 UTC
Ok, so now we have:
- icon text that can be shown/hidden
- icon size that can be changed, and reduced up to 22x22

Could you try the svn version and tell us if the current settings are enough or not? (and in case close this bug report)
Thanks!
Comment 5 Roland Leißa 2007-11-02 00:19:13 UTC
looks great. Thx :)
Comment 6 Roland Leißa 2007-11-02 00:19:49 UTC
... and resolved
Comment 7 Nick Shaforostoff 2007-12-01 14:03:57 UTC
sorry if i missed this, but this sidebar tabs organization: http://season.openusability.org/wp-content/uploads/projects/okular/okular-toolbar.jpg seems to be  a lot better.

why don't you switch to it?
Comment 8 Pino Toscano 2007-12-01 14:42:31 UTC
The sidebar in that image was exactly the situation before the new sidebar.
Comment 9 Nick Shaforostoff 2007-12-01 15:18:58 UTC
ah, i see. http://www.kdedevelopers.org/node/2922

back then the points were:
- Too much space taken by the tabs of the toolbox
well, it depends on the number of tabs. in the case of okular it's only 4 of them. and if the window is maximized, the new layout actually uses more space (~10k pixels on 1280X1024 is empty in the icon mode, and >30kpixels in icons+text, while janusview would take no more then 5k pixels, _and_ wideness is more important than vertical size for book reading)

"jumping" tabs - that means, the "label" of each tab had a different position, depending on the open ones (of course, not for the first)
it's only 2 places to look at, on the other hand the text is always shown, so no remembering is needed. OR we can use usual tabs (several tabs in one line)...

-No way to change the active tab of the toolbox using the keyboard (that is what was also reported by the KPDF's bug 132152
i doubt it depends on the view itself!

-not really good-looking (not a real issue, just a taste that many people made me notice)
there are different tastes

and regarding the first comment of your blog entry: the gnome app screenshots show that tabwidget controls whole-window pages, while in the case of okular it's just a sidebar.

so i'm gonna reimplement januswidget in kpageview and add it as an option to okular.
Comment 10 Pino Toscano 2007-12-01 15:30:08 UTC
> - Too much space taken by the tabs of the toolbox 
> well, it depends on the number of tabs.

And _also_ by the style. If the style draws big toolbox tabs, they can take much more space.

> "jumping" tabs - that means, the "label" of each tab had a different
> position, depending on the open ones (of course, not for the first) 
> it's only 2 places to look at, on the other hand the text is always shown,
> so no remembering is needed. OR we can use usual tabs (several tabs in one
> line)... 

Sure, drop them. Nice way to get rid of usability improvements, sure.

> -No way to change the active tab of the toolbox using the keyboard (that is
> what was also reported by the KPDF's bug 132152 
> i doubt it depends on the view itself! 
 
You're wrong. Just for curiosity, are you actually pondering or not?

> -not really good-looking (not a real issue, just a taste that many people
> made me notice) 
> there are different tastes 

Just like your comment :)

> so i'm gonna reimplement januswidget in kpageview and add it as an option to okular. 

Please please PLEASE, instead of just declaring that something decided taking usability into account is not an option because *YOU* don't like it, could you please bring the discussion to the mailing list, and not to this bug report?
Comment 11 Pino Toscano 2008-03-13 22:46:08 UTC
*** Bug 159253 has been marked as a duplicate of this bug. ***
Comment 12 Mike Frysinger 2008-11-08 14:23:48 UTC
remind me why it cant simply be an option for the user to decide ?  clearly the way kpdf did things (as shown in Comment #7) has advantages over the way okular does things now (as shown in Comment #9), and vice versa.  i find the amount of space wasted on all of 4 icons a bit ridiculous, especially when i spend most of the time using the contents tab only.  yes, the whole toolbar can be hidden, but that's sort of pointless when all you want is the contents in the first place.