Bug 150469 - Enable interval mail checking by default
Summary: Enable interval mail checking by default
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Thorsten Staerk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-04 14:45 UTC by Thorsten Staerk
Modified: 2012-08-19 00:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
doNotAutoCheckMailIfNetworkingDown.diff (585 bytes, text/x-diff)
2007-10-05 01:26 UTC, Aaron J. Seigo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Staerk 2007-10-04 14:45:56 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

please enable interval mail checking by default
This is a bug because the enterprise user just does not expect it to not occur. A major blocker for me, I plan to change it.
Comment 1 Allen Winter 2007-10-04 16:20:28 UTC
feel free to fix this in the 3.5 branch.
I'll forward port it to trunk once you have finished in branch.

better hurry... 3.5.8 tagging happens on 7 Oct.
Comment 2 Thorsten Staerk 2007-10-05 00:45:08 UTC
SVN commit 721291 by tstaerk:

enable interval mail checking by default
BUGS:150469


 M  +14 -12    accountdialog.cpp  
 M  +2 -0      globalsettings.h  
 M  +6 -3      kmaccount.cpp  
 M  +5 -1      kmaccount.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=721291
Comment 3 Dominik Haumann 2007-10-05 01:04:59 UTC
On Friday 05 October 2007, Thorsten Staerk wrote:
> SVN commit 721291 by tstaerk:
>
> enable interval mail checking by default
> BUGS:150469


What about users who do not always have an internet connection?
KMail then pops up a annoying message box for *every* account saying it 
couldn't connect to the server. If you have bad luck, you mess up the order 
of the message boxes in which case it's really hard to find the right order 
to close them again ;) Maybe something to consider...
Comment 4 Aaron J. Seigo 2007-10-05 01:26:42 UTC
On Thursday 04 October 2007, Dominik Haumann wrote:
> On Friday 05 October 2007, Thorsten Staerk wrote:
> > SVN commit 721291 by tstaerk:
> >
> > enable interval mail checking by default
> > BUGS:150469
>
> What about users who do not always have an internet connection?
> KMail then pops up a annoying message box for *every* account saying it
> couldn't connect to the server. If you have bad luck, you mess up the order
> of the message boxes in which case it's really hard to find the right order
> to close them again ;) Maybe something to consider...


this is where Solid should come into play, right? in the kmail code it should 
probably not try to do an automatic mail check if the network isn't up... 
something like the totally untested attached patch, maybe.... 


Created an attachment (id=21753)
doNotAutoCheckMailIfNetworkingDown.diff
Comment 5 Thorsten Staerk 2007-10-05 09:46:18 UTC
Reopening because of 
- Dominik's comment
- although fixed in branches, it is still open in trunk
Comment 6 Maciej Pilichowski 2007-10-05 19:19:46 UTC
Strange report, because regular user does not expect the auto check is on. And this is hardly a bug by any means. Besides you should set this option once in your lifetime.

Comment 7 Thomas McGuire 2007-10-19 19:41:19 UTC
Changing to a wish, because this is not a bug.
Comment 8 Thorsten Staerk 2008-08-15 14:01:11 UTC
Maciej, I completely disagree. An inspiring article about why is here: http://www.joelonsoftware.com/uibook/chapters/fog0000000059.html 
I really recommend reading it to everyone. It addresses your statement with the sentence: "Most advanced users use several computers regularly; they upgrade their computer every couple of years, they reinstall their operating system every three weeks."
Comment 9 Myriam Schweingruber 2012-08-18 08:37:00 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 10 Luigi Toscano 2012-08-19 00:25:13 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.