Bug 150065 - (d)imap cache rebuild crash
Summary: (d)imap cache rebuild crash
Status: RESOLVED DUPLICATE of bug 148412
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-21 16:02 UTC by Donatas Glodenis
Modified: 2007-11-02 17:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrase of the crash (6.72 KB, text/plain)
2007-09-21 16:07 UTC, Donatas Glodenis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Donatas Glodenis 2007-09-21 16:02:47 UTC
Version:           1.9.7 (using KDE 3.5.7, Kubuntu (feisty) 4:3.5.7-0ubuntu1~feisty2)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-16-generic

I tried to rebuild my inbox imap cache and Kmail crashed. After restarting kmail I saw just one (out of 300) emails in the folder. They were still present in the server, can see that through webmail service. 

I will also attach the backtrace I receive every time I try to rebuild the folder cache and kmail crashes (it does every time).
Comment 1 Donatas Glodenis 2007-09-21 16:07:12 UTC
Created attachment 21668 [details]
Backtrase of the crash

I get this every time now I try to rebuild the cache of inbox (though it is not
the backtrace I got the first time it crashed with data loss - I did not know
it will be serious...)
Comment 2 Donatas Glodenis 2007-09-21 16:14:57 UTC
By the way, I tried to rebuild caches of other folders (with unimportant data) on that account - success, no crashes.
Comment 3 Jaka Kranjc 2007-10-18 15:09:07 UTC
I get the same crash since the update to kdepim 3.5.8. The backtrace is the same. There is no mail loss.
Comment 4 Thomas McGuire 2007-11-02 17:44:39 UTC

*** This bug has been marked as a duplicate of 148412 ***