Bug 149873 - Kmail account settings get out of sync when changing them
Summary: Kmail account settings get out of sync when changing them
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-14 22:44 UTC by Alex Dănilă
Modified: 2008-04-03 21:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Dănilă 2007-09-14 22:44:58 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-8 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-5-k7

Steps to reproduce:
-Create a new accout for sending e-mails, with some wrong settings, such that it doesn't work
-write an e-mail and try so send it with the wrong smtp account, be sure it doesn't work
-fix the account and try to send the e-mail again. Kmail will try to send it with the old wrong settings.
-try to send the message again, now click on the sending identity and choose the newly repaired identity, now sending the e-mail should work

Same bug:
If you change the name of one of the sending accounts Kmail will be confused and say something like "unknown transport" (I don't know the actual message in English since I use it in Romanian). 
It is quite confusing and I didn't test all the posible combinations, but in order to make things work you kind of have to go to all the comboboxes related to sending messages and click on them to force an update.
Comment 1 Thomas McGuire 2008-04-03 21:02:55 UTC
I just tested it with the KDE4 version, and there, it works.
In KDE4, KMail uses the new mailtransport library, that seems to fix the problem. 
Changing the name shouldn't be a problem now, too, since the new library uses unique IDs to identify transports.