Bug 149591 - The export menu is blank.
Summary: The export menu is blank.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Menus (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-06 04:34 UTC by Jed Campbell
Modified: 2018-02-04 08:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jed Campbell 2007-09-06 04:34:48 UTC
Version:           0.9.2 (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

The export menu no longer has any entries.  I have tried reinstalling the packages (digikam, kipi-plugins, digikamimageplugins, showfoto) in many different combinations, and from version 9.1 and 9.2, to no avail.

I booted the gusty tribe 5 cd, and the export version works just fine.  I would prefer not to reinstall, but would like to find out why the menu has stopped giving choices. 

Any ideas?
Comment 1 Arnd Baecker 2007-09-06 07:35:11 UTC
Did you use Achim Bohnet's packages referred to  at 
http://www.digikam.org/?q=download/binary/ ?

(Sometimes running `kdeinit` just once after installation did help 
wonders for me in a situation sounding similar ...)

Which versions are listed under "Help"/"About digikam"
Comment 2 caulier.gilles 2007-09-06 07:50:22 UTC
Jed,

All options in Export menu are provided by kipi-plugins. Check in setup/plugins page of digiKam if plugins list is available and if all tools are enable.

Gilles Caulier
Comment 3 Jed Campbell 2007-09-06 14:15:17 UTC
Tried 'kdeinit' - no dice.

Versions = 
Kipi library 0.1.5
KExiv2 0.1.1
Exiv2 0.12.0
PNG 1.2.15beta5
Gphoto 2.3.0

The plugins page lists a lot of plugins, including the a few export ones (ipod, remote galllery, html, etc)

Maybe it's time to switch to kubuntu?
Comment 4 Jed Campbell 2007-09-06 14:24:37 UTC
Using Achim's packages upgraded me to 0.9.2 final

Kipi 0.1.5
KExiv2 0.1.5
Exiv2 0.14.0
KDcraw 0.1.1
Dcraw 8.60
PNG 1.2.15beta5
Gphoto 2.3.0

Still no export menu.  Thanks for all your help so far.
Comment 5 caulier.gilles 2007-11-06 14:41:25 UTC
Achim,
 
Whats wrong here with your packages ?

Gilles
Comment 6 caulier.gilles 2007-11-06 14:42:14 UTC
Jed,

Are you installed "kipi-plugins" package on your system ?

Gilles
Comment 7 Achim Bohnet 2007-11-06 21:17:37 UTC
That's really strange.  I've received no other reports about
problems with kipi-plugins menu entries.

The 21 kipi plugins are listed and enabled in settings -> configure digikam ->
kipi plugins?


What's the output of

 strace digikam 2>&1 | grep kipi | grep /usr/lib

You should get repeatedly for each plugin:

open("/usr/lib/libkipi.so.0", O_RDONLY) = 3
access("/usr/lib/kde3/kipiplugin_jpeglossless.la", R_OK) = 0
stat64("/usr/lib/kde3/kipiplugin_jpeglossless.la", {st_mode=S_IFREG|0644, st_size=1738, ...}) = 0


Another check would be: create a new test user account  and start digikam
there.

Achim

Comment 8 Jed Campbell 2007-11-07 02:00:50 UTC
I have wiped everything and re-installed kubuntu gutsy--problem solved.  Thanks for your help!
Comment 9 caulier.gilles 2007-11-07 06:40:36 UTC
*** Bug has been marked as fixed ***.
Comment 10 Ben 2008-06-07 23:46:26 UTC
I had the same issue after installing from a gutsy backport list.  I could see all the options in the Export menu but they were grayed out.

removing the digikamrc file in .kde/config fixe this issue.
Comment 11 Ben 2008-06-07 23:47:33 UTC
my bad, that should be  ./.kde/share/config/digikamrc
Comment 12 caulier.gilles 2018-02-04 08:35:11 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core