Bug 149525 - SIGSEGV after clicking on scroll bar
Summary: SIGSEGV after clicking on scroll bar
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 149529 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-03 19:49 UTC by Tristan Miller
Modified: 2007-09-05 15:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2007-09-03 19:49:44 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

Kontact crashed with a SIGSEGV; the last thing I did was to click on the scroll bar of the folder pane.  Backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1240881456 (LWP 22061)]
[New Thread -1284482160 (LWP 22219)]
[New Thread -1276089456 (LWP 22218)]
[New Thread -1267696752 (LWP 22217)]
[New Thread -1259304048 (LWP 22216)]
[KCrash handler]
#9  0xb52f3e4d in KMAcctLocal::fetchMsg ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb52f41cf in KMAcctLocal::continueProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb52f5255 in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb6cceb11 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb6ccf275 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb52f353b in KMAcctLocal::preProcessExited ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb52f503d in KMAcctLocal::continuePreProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#16 0xb52f526f in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#17 0xb6cceb11 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb6ccf275 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb526594b in KMAccount::precommandExited ()
   from /opt/kde3/lib/libkmailprivate.so
#20 0xb52672fe in KMAccount::startPrecommand ()
   from /opt/kde3/lib/libkmailprivate.so
#21 0xb52f461a in KMAcctLocal::preProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#22 0xb52f47e9 in KMAcctLocal::processNewMail ()
   from /opt/kde3/lib/libkmailprivate.so
#23 0xb52ed440 in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb52ed710 in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#25 0xb5265a70 in KMAccount::mailCheck () from /opt/kde3/lib/libkmailprivate.so
#26 0xb5265d33 in KMAccount::qt_invoke () from /opt/kde3/lib/libkmailprivate.so
#27 0xb52f51e3 in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#28 0xb6ccebad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6ccf7ed in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb700b959 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb6cf23cf in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb6c6f657 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6c70421 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb731e5a2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#35 0xb6c64863 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb6c1e4f0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb6c86480 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb6c86316 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb6c6f20f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x0805a759 in main ()
Comment 1 Tristan Miller 2007-09-03 19:52:29 UTC
I should add, this was in the KMail component.
Comment 2 Tristan Miller 2007-09-03 22:55:37 UTC
I'm now getting crashes every few minutes, often when the application is running idle.  This follows upgrading to kdepim3-3.5.7.enterprise.0.20070831.706868-18.1 (SUSE RPM).  The latest backtrace is a bit different:

System configuration startup check disabled.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1241004336 (LWP 3395)]
[New Thread -1284625520 (LWP 3563)]
[New Thread -1276232816 (LWP 3562)]
[New Thread -1267840112 (LWP 3561)]
[New Thread -1259447408 (LWP 3560)]
[KCrash handler]
#9  0xb52d0e4d in KMAcctLocal::fetchMsg ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb52d11cf in KMAcctLocal::continueProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb52d2255 in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb6cb0b11 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb6cb1275 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb52d053b in KMAcctLocal::preProcessExited ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb52d203d in KMAcctLocal::continuePreProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#16 0xb52d226f in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#17 0xb6cb0b11 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb6cb1275 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb524294b in KMAccount::precommandExited ()
   from /opt/kde3/lib/libkmailprivate.so
#20 0xb52442fe in KMAccount::startPrecommand ()
   from /opt/kde3/lib/libkmailprivate.so
#21 0xb52d161a in KMAcctLocal::preProcess ()
   from /opt/kde3/lib/libkmailprivate.so
#22 0xb52d17e9 in KMAcctLocal::processNewMail ()
   from /opt/kde3/lib/libkmailprivate.so
#23 0xb52ca440 in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb52ca710 in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#25 0xb5242a70 in KMAccount::mailCheck () from /opt/kde3/lib/libkmailprivate.so
#26 0xb5242d33 in KMAccount::qt_invoke () from /opt/kde3/lib/libkmailprivate.so
#27 0xb52d21e3 in KMAcctLocal::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#28 0xb6cb0bad in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6cb17ed in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6fed959 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb6cd43cf in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb6c51657 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6c52421 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb73005a2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#35 0xb6c46863 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb6c004f0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb6c68480 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb6c68316 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb6c5120f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x0805a759 in QWidget::setUpdatesEnabled ()
#41 0xbfdf0798 in ?? ()
#42 0x00000001 in ?? ()
#43 0x00000001 in ?? ()
#44 0x00000000 in ?? ()
Comment 3 Bram Schoenmakers 2007-09-04 08:12:10 UTC
*** Bug 149529 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Kilgus 2007-09-04 18:31:01 UTC
Latest packages, released this afternoon, at least solved my duplicate. :)
Comment 5 Thomas McGuire 2007-09-05 15:17:35 UTC
>Latest packages, released this afternoon, at least solved my duplicate. :) 
Yep, this one should be solved too. Please reopen if you can still reproduce it with newer versions.