Bug 149230 - Quoting of ellipsis character failes
Summary: Quoting of ellipsis character failes
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-26 14:38 UTC by Ronny Standtke
Modified: 2009-01-18 15:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2007-08-26 14:38:46 UTC
Version:           1.9.5 (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-4 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.21-2-686

If someone sends me a mail with an ellipsis character (…) in the text and I answer this mail, kmail messes up the quotation of this character. In the quotation the ellipsis character shows up as a rectangle ().
Comment 1 Ronny Standtke 2007-08-26 14:47:04 UTC
Additional info:
I use exactly the same font for "Message Body" and "Quoted Text - First Level" (Bitstream Vera Sans Mono, Regular, 10).
Comment 2 Thomas McGuire 2007-08-27 14:42:18 UTC
Please attach such a mail with this character.
Where do you see the rectangle? In the composer?
What is the charset of the original mail?
Does changing fonts help?
Comment 3 Ronny Standtke 2007-08-27 15:26:54 UTC
> Please attach such a mail with this character.

I can't do this because of privacy reasons. I looked at the source code of one of these mails and can provide some (hopefully) important parts here:

---------------8<---------------
This is a multi-part message in MIME format.

------=_NextPart_000_0205_01C7E641.A88DDA80
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
---------------8<---------------

In the text the ellipsis is encoded with "=85", e.g. like this:

---------------8<---------------
eine kleine Aufgabe l=F6sen =85
---------------8<---------------

> Where do you see the rectangle? In the composer?
Yes.

> What is the charset of the original mail?
iso-8859-1

> Does changing fonts help?
No. In fact, the composer seems to ignore font settings completely and changes to "Quoted Text - First Level" are only possible regarding font style and size but are lost when the configuration dialog is closed. Nice, everywhere I go I run into bugs...
Comment 4 Maciej Pilichowski 2007-08-27 19:05:10 UTC
Is this character valid for ISO-8859-1? I tried to reproduce it by sending such mail to myself but KMail with this encoding changes 
…
into
?

With UTF-8 everything works fine.
Comment 5 Ronny Standtke 2007-08-28 21:51:05 UTC
> Is this character valid for ISO-8859-1?
ASCII only goes from 00 to 7F, and ISO-8859-1 from A0 to FF. Unfortunately I have no idea what is with the range from 80 to 9F. This is where the ellipsis "=85" falls into...

I also tried sending mail to myself and just run into the next bug: Bug#149309
Great.
Comment 6 Thomas McGuire 2009-01-18 15:44:50 UTC
This bug seems to be fixed now, I can't reproduce anymore.