Bug 149181 - Frequent crashes when sending or checking mail
Summary: Frequent crashes when sending or checking mail
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: sending (show other bugs)
Version: enterprise
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-25 00:27 UTC by R S Prigan
Modified: 2007-09-04 20:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R S Prigan 2007-08-25 00:27:16 UTC
Version:           1.9.6 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

since latest openSUSE Build Service KDE 3.5.7 update to 3.5.7.enterprise.0.20070731.694771-11.1, kmail 1.9.6 crashes on sending mail, checking mail, etc.
crash log:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1248794400 (LWP 5138)]
[New Thread -1279202416 (LWP 5143)]
[New Thread -1270809712 (LWP 5142)]
[New Thread -1262417008 (LWP 5141)]
[New Thread -1254024304 (LWP 5140)]
[KCrash handler]
#9  0xb7bba61a in KMMessage::setUnencryptedMsg ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb7cd9d56 in KMSender::doSend () from /opt/kde3/lib/libkmailprivate.so
#11 0xb7c837a8 in KMComposeWin::slotContinueDoSend ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb7c86281 in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0xb7359f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb735a5e5 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb7c6285b in KMComposeWin::applyChangesDone ()
   from /opt/kde3/lib/libkmailprivate.so
#16 0xb7c6414e in KMComposeWin::slotComposerDone ()
   from /opt/kde3/lib/libkmailprivate.so
#17 0xb7c86262 in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#18 0xb7359f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb735a5e5 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb7e78c9b in MessageComposer::done ()
   from /opt/kde3/lib/libkmailprivate.so
#21 0xb7e7eaa9 in MessageComposer::emitDone ()
   from /opt/kde3/lib/libkmailprivate.so
#22 0xb7e7ebee in MessageComposer::doNextJob ()
   from /opt/kde3/lib/libkmailprivate.so
#23 0xb7e7ec35 in MessageComposer::slotDoNextJob ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb7e7ed12 in MessageComposer::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#25 0xb7359f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb76950ae in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb7375ff7 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb737d383 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb72fa9c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb72fb791 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb79b18d2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0xb72efbd3 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb72a9c40 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb73117f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb7311686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb72fa57f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x0804a0fb in main ()
Comment 1 Thomas McGuire 2007-08-27 13:45:56 UTC
The enterprise builds are not officially supported by Novell or released by KDE. Please try to see if the crashes also happen with the normal KMail (1.9.7) or with an up-to-date enterprise branch (AFAIK Novell's enterprise branch is frozen since some time).
Comment 2 Will Stephenson 2007-08-27 14:02:18 UTC
The enterprise stuff is unsupported for 10.2 (the PIM packager at Novell), but I'm interested anyway.   Can you give exact steps to reproduce?  Are you using 10.2 or 10.3?

Comment 3 R S Prigan 2007-08-27 20:51:00 UTC
ANY TIME I attempt to send email, kmail crashes.  Using OpenSUSE 10.2.

I had had *great* problems with data corruption/loss in synching Palm 3xe datebook and addressbook with 10.2's stock (3.5.5) Kaddressbook and Korganizer (apparently a kpilot issue across distros).
https://bugzilla.novell.com/show_bug.cgi?id=228920
http://cvs.codeyard.net/kpilot/news.php

The KDE 3.5.6 builds failed to fix.
The 3.5.7 stuff from
  http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_10.2/i586/
worked like a charm.

Kmail went bad when I cavalierly updated KDE 3.5.7 to a later build from this same repository that contained the *enterprise* versions of kdepim apps.
I also noted that the same latest build (20 Aug 2007 most dates) has intermittent problems with konqueror (!) failing to launch, with the following message:
scott@k7:~> konqueror
      4910:     Warning: unresolved direct binding for symbol '_ZN31StatusBarNetworkStatusIndicatorC1EP7QWidgetPKc' (error 0)
konqueror: symbol lookup error: /opt/kde3/lib/libkdeinit_konqueror.so: undefined symbol: _ZN31StatusBarNetworkStatusIndicatorC1EP7QWidgetPKc

I have now reverted to KDE 3.5.5 stuff, and have to figure out how to sync my Palm ...

I think I'll try again when a new build is posted.
Comment 4 Bruno Virlet 2007-08-28 11:51:07 UTC
If you could provide a backtrace it could be really helpful.
Comment 5 Will Stephenson 2007-08-30 18:58:45 UTC
It's an error in the current build service packages, we are updating them with a fix...
Comment 6 Will Stephenson 2007-09-03 09:54:00 UTC
R S Prigan:  the missing symbol indicates that you did not upgrade all your kde packages together and now have an inconsistent install.  I recommend you reinstall everything from KDE:KDE3 and then check afterwards with rpm -V kdelibs3 kdepim3 that all is well.
Comment 7 R S Prigan 2007-09-04 20:25:13 UTC
There has been a flurry of updates on the openSUSE Build Service KDE 3.5.7
    http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_10.2/i586/ 

The two tagged 3.5.7.enterprise.0.20070831... were problemmatic: crashes after claiming UIDL not implemented on server, failure to keep UIDL data (thus multiple fetching of messages), and crash on attempt to delete some of these messages.

The updates I found posted today, 3.5.7.enterprise.0.20070904.708281-3.1, seems to have answered all the kmail issues!

Thanks to the team for good work!