Bug 148740 - Remember playback position for long files, synch with iPods and other devices
Summary: Remember playback position for long files, synch with iPods and other devices
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0-SVN
Platform: Debian stable Linux
: NOR wishlist with 15 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 119356 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-11 14:13 UTC by Cory Doctorow
Modified: 2009-12-09 11:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cory Doctorow 2007-08-11 14:13:14 UTC
Version:           3.5.6 (using KDE KDE 3.5.6)
Installed from:    Debian stable Packages

When I stop listening to a long track, or spoken word track -- such as an audiobook or a podcast -- Amarok should remember the playback position, so that when I restart the track, it restarts from the last-played position. That way, I can listen to audiobooks for a while, pause it, listen to music, and then pick up the audiobook from where I left off. 

The playback position information should synch with the iPods (which already have this feature with iTunes).

This feature should only be turned on for tracks that are flagged as "Remember playback position" via a checkbox in the Properties window.
Comment 1 Sebastien 2007-11-12 00:00:20 UTC
I think iTunes has no such "Remember playback position" checkbox.
It would be too complicated to check that manually, and people will not know it is possible.
I think iTunes know it's a podcast, and then enable that feature automatically.
Comment 2 Myriam Schweingruber 2008-06-17 16:34:42 UTC
Amarok 1.4.x is in bugfix-only mode as development is focused on Amarok 2. Unfortunately your feature request can not be implemented in Amarok 1, as Amarok developers do not have the resources for it and risk of regression would be too high. I am therefore moving your request to Amarok 2. I cannot make any guarantee as to whether is will get implemented there or not though. Thank you for your report.
Comment 3 Lydia Pintscher 2008-06-23 11:09:24 UTC
*** Bug 119356 has been marked as a duplicate of this bug. ***
Comment 4 Dan Meltzer 2008-07-12 00:45:34 UTC
This should be implemented when we add real bookmarking support, which hopefully will be done for 2.1
Comment 5 Casey Link 2008-07-12 03:12:58 UTC
I've drawn up a proposal for this feature:
http://amarok.kde.org/wiki/Proposals/Bookmarking
Comment 6 Casey Link 2009-02-17 20:51:30 UTC
SVN commit 927532 by link:

Add the Auto-Timecode feature. Now, when ever a track with length > 10
minutes is being played and a stop or skip action occurs a bookmark is
automatically created at the last position played.
Audiobook and Podcast listeners rejoice.
~yay
CCMAIL: amarok-devel@kde.org
BUG: 148740

 M  +2 -0      ChangeLog  
 M  +2 -0      src/CMakeLists.txt  
 M  +3 -0      src/amarokurls/AmarokUrlHandler.cpp  
 M  +2 -0      src/amarokurls/AmarokUrlHandler.h  
 M  +2 -1      src/meta/capabilities/TimecodeWriteCapability.cpp  
 A             src/timecode (directory)  
 A             src/timecode/TimecodeObserver.cpp   [License: GPL (v2+)]
 A             src/timecode/TimecodeObserver.h   src/meta/capabilities/TimecodeWriteCapability.cpp#927531 [License: GPL (v2+)]


WebSVN link: http://websvn.kde.org/?view=rev&revision=927532
Comment 7 Casey Link 2009-02-17 21:07:20 UTC
media device syncing of bookmarks is not implemented yet.

Please see bug 148740 for this extra feature.