Bug 148700 - Crash upon sending mail
Summary: Crash upon sending mail
Status: RESOLVED DUPLICATE of bug 108312
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-09 22:46 UTC by Tristan Miller
Modified: 2008-11-26 12:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2007-08-09 22:46:01 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

It's happened twice today already that Kontact crashes upon sending mail.  I'm in the KMail component, reply to a message, and click the "Send" icon in the composer window toolbar, and Kontact crashes with the following backtrace.

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241045296 (LWP 3611)]
[New Thread -1284256880 (LWP 3807)]
[New Thread -1275864176 (LWP 3806)]
[New Thread -1267471472 (LWP 3805)]
[New Thread -1259078768 (LWP 3804)]
[KCrash handler]
#9  0xb5248f2a in KMMessage::asDwString ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb53115a7 in KMComposeWin::autoSaveMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb53124c8 in KMComposeWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb6ca1f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb6ca2b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb6fdf299 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb6cc573f in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb6c429c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb6c43791 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb72fdd32 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#19 0xb6c37bd3 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb6bf1c40 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6c597f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6c59686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb6c4257f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x08058c59 in main ()
Comment 1 Thomas McGuire 2007-08-10 00:29:41 UTC
Although you probably don't have a ferret, this is the same bug as bug 108312. (Backtraces of bug 143003, which is another duplicate, and this one match)

*** This bug has been marked as a duplicate of 108312 ***
Comment 2 Tristan Miller 2007-08-24 18:36:04 UTC
Of course I have a ferret.  I'm the one who reported Bug 108312. :)