Bug 148191 - Using DIMAP on network shares causes dataloss
Summary: Using DIMAP on network shares causes dataloss
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: disconnected IMAP (show other bugs)
Version: 1.9.7
Platform: Debian testing Linux
: NOR grave with 41 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2007-07-25 09:56 UTC by Cajus Pollmeier
Modified: 2018-09-04 18:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cajus Pollmeier 2007-07-25 09:56:20 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Debian testing/unstable Packages
Compiler:          g++ (GCC) 4.1.3 20070718 (prerelease) (Debian 4.1.2-14) 
OS:                Linux

If you have your home directory on a network share (i.e. NFS, AFS, etc.) and the network connection is down (or the share is not available for other reasons), KMAIL starts to delete folders from the IMAP server in DIMAP mode. Shared folders with write permission and personal folders are affected.
Mails not captured by a backup or other client are lost.
Comment 1 Thomas McGuire 2007-07-25 15:32:55 UTC
Probably a duplicate of either bug 143263 or bug 65571. Please check that.
Comment 2 Cajus Pollmeier 2007-07-25 15:57:29 UTC
Its more like 65571 but you don't even need to restart any kmail sessions. For AFS, for i.e., you might just want to use "unlog" or wait until your token expires and kmail starts to purge all mails on the server.
Comment 3 Björn Ruberg 2010-01-09 01:05:28 UTC
Is this still a problem with recent kmail versions?
Comment 4 Andrew Crouthamel 2018-09-04 18:23:34 UTC
Hello! Sorry to be the bearer of bad news, but this version of Kmail has been unmaintained for many years so I am closing this bug. Please try using the latest version of Kmail to see if your issue persists. If it does, please submit a new bug in "kmail2". Thank you!