Bug 147797 - unable to correct spelling mistake of first word in the body part
Summary: unable to correct spelling mistake of first word in the body part
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-11 21:59 UTC by Nadav Kavalerchik
Modified: 2008-05-02 16:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Kavalerchik 2007-07-11 21:59:50 UTC
Version:           1.9.7 (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.21-2-686

when i make a spelling mistake with the first word on the body part of an email, it gets red color but i'm unable to get a spelling correction (suggestion) menu when i right click it.

anywhere else it work fine.
Comment 1 Thomas McGuire 2007-07-12 19:37:18 UTC
I can not reproduce this. For me, right-clicking the first word works fine and brings up the usual list of suggested words.
Comment 2 Nadav Kavalerchik 2007-07-12 19:49:03 UTC
you are right, sorry ;-)

let me be more specific.
it only happens when i use..."i've" or "i'm" 
everywhere in the text, not just the first word.
Comment 3 Allen Winter 2007-07-12 19:51:54 UTC
confirmed.
but why in the world are we marking "i've" or 'i'm" as misspellings?

I wonder if we need to pass a special "allow contractions" option to aspell?
Comment 4 Thomas McGuire 2007-07-12 19:56:07 UTC
> but why in the world are we marking "i've" or 'i'm" as misspellings?

Because it should be "I've" instead (capital I) :)

My hope is that Laurent's shiny new kmeditor will solve problems like those.
Comment 5 Allen Winter 2007-07-12 20:25:47 UTC
Ah right.

Interestingly, if I run aspell on a file containing "i've", I am shown
a list of alternate spellings.

This seems to be a problem with K3Spell.  Maybe sonnet will fix in KDE4.
Comment 6 Thomas McGuire 2008-05-02 16:27:27 UTC
This is now indeed fixed in Sonnet, things like "I've" are now considered as one word.