Bug 147706 - search asks whether I want to download all messages for each folder
Summary: search asks whether I want to download all messages for each folder
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: search (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 113879 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-09 16:47 UTC by Olivier Vitrat
Modified: 2015-04-12 10:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Vitrat 2007-07-09 16:47:03 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Debian stable Packages

Reported in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=384865

Hello,

If I try to perform a slightly more complicated search (say, do regexp
matching for the Subject header) over IMAP, I get the following message:

    "To execute your search all messages of the folder xxx have to
     be downloaded from the server. This may take some time. Do you
     want to continue your search?

     [ ] Do not ask again

     [Search] [Cancel]"

Ok, this was unexpected, I do not want to wait for kmail to download
all messages in all folders this time. I just hit "cancel" and expect
it to stop.

However, it does _not_ stop searching, it simply skips to the next
folder. It asks the same question again, I hit "cancel" again, and so
on. Finally, I figure out a way to kill kmail as I do not have
patience to say "cancel" for all folders.

Naturally, checking "do not ask again" does not help if I hit
"cancel"; it simply keeps asking again.

Best regards,
Jukka Suomela
Comment 1 Thomas McGuire 2007-07-09 17:49:32 UTC
See also bug 113879
Comment 2 Michael Leupold 2009-04-05 10:03:36 UTC
This is still reproducible on trunk r948809.
Comment 3 Jaime Torres 2009-04-21 12:27:57 UTC
This happens because KMessageBox::warningContinueCancel does not saves the "do not ask me again" when cancel is used.
And this warning is called in each imap folder searched that is not able to do the search in the server.

I think this could be solved by:
changing the use of warningContinueCancel to warningYesNo.

And I guess wish #190238 should be implemented also.
Comment 4 Jaime Torres 2009-04-21 12:29:19 UTC
*** Bug 113879 has been marked as a duplicate of this bug. ***
Comment 5 Laurent Montel 2015-04-12 10:00:18 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.