Bug 147515 - Large context menues activate some entry by default
Summary: Large context menues activate some entry by default
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: qt (show other bugs)
Version: 3.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-03 21:32 UTC by David Gallagher
Modified: 2009-04-15 16:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Gallagher 2007-07-03 21:32:17 UTC
Version:           1.9.7 (using KDE 3.5.7, compiled sources)
Compiler:          Target: i586-mandriva-linux-gnu
OS:                Linux (i686) release 2.6.18.8.tex5

This may be a general KDE operational issue.  In both Kmail and Konqueror, if you right-click on a drop down menu item with a large number of entries like Spellchecker for the misspelled word "speel" the list of options should be "drop down" and start below (or above if towards bottom of screen page) the position of the cursor. Instead, it fills up the whole height of the user's screen with the options in the list such that one of the options is now directly under the user's cursor position and thus when you release the right-click button it selects that entry which is wrong. The list needs to remain open until the end user selects the correct choice via a left-click action. This also can happen in Konqueror if you click on the Bookmarks button and you have a moderate amount of bookmarks - depressing the left-click button while over the Bookmark button opens the drop-down list but if alot of entries it fills to the top of the screen and when you release the button it selects what ever is under the cursor position. Again, it should start beneath the cursor position (note if the item happens to be a Folder then you luck out and the contents of the folder are displayed in a subfolder but if the item an actual URL entry then it gets selected/launched).
Comment 1 Thomas McGuire 2007-07-09 18:55:27 UTC
This is probably a general Qt or kdelibs issue, but it is not a KMail issue.

See also bug 97995.
Comment 2 David Gallagher 2007-07-09 20:04:57 UTC
Thanks Thomas for the input. I suspected it is not a direct Kmail issue nor likely not a direct Konqueror issue either, but this "but" definitely affects the useability of both applications. Would this be better moved to a different category, and if so how to move it? Konqueror is particularly impacted and is why I use Thunderbird as the default browser. Another negative side-affect of this is that since the drop-down (should this be drop-all-around? ;) menu appears above,over, and below the button/cursor location (instead of starting below the button/cursor location) it covers up the rest of the menu buttons such that you have to start over in the menu system of move back to a previous button to switch to that hopefully shorter dropdown and then slide the cursor around the Bookmarks button to get to the other items).

Bug 97995 may be related, but it is not the same as this one (that one seems to be more specific to his PC/config and loosing entries beyond the screen window boundaries).
Comment 3 Thomas McGuire 2007-07-18 21:08:42 UTC
>Would this be better moved to a different category, and if so how to move it?
I've moved it to kdelibs/qt, which seems appropriate to me, as this probably is a Qt issue.
Comment 4 Olivier Goffart 2009-04-15 16:11:03 UTC
Please report the bug to qt-bugs@trolltech.com if the problem persist in recent qt versions.