Bug 147503 - to much hints --> not responding
Summary: to much hints --> not responding
Status: RESOLVED FIXED
Alias: None
Product: kwordquiz
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Hedlund
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-03 17:49 UTC by flo
Modified: 2007-09-18 22:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flo 2007-07-03 17:49:28 UTC
Version:           0.8.1 (using KDE 3.5.5, Gentoo)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.20-gentoo-r8

In the question and answer session is a bug which let KWordQuiz crash. If you press the "Hint" button as often as possible (until there isn't any more character to display and the searches word is complete) and then press "Check" or Return KWordQuiz isn't responsing anymore. When you then press the X in the top right corner of the window a warning from KWin comes and you can either choose to terminate KWordQuiz or to keep it running.
You can reproduce it as often as you want...
Comment 1 flo 2007-07-03 17:53:37 UTC
The described problem only arises when "Treat hint as error" is activatet in the Quiz settings.
Comment 2 Philip Rodrigues 2007-07-04 00:10:02 UTC
When KWordQuiz freezes, try killing it with "kill -SEGV <pid-of-kwordquiz>". That might get you a backtrace. If so, please paste it here.
Comment 3 flo 2007-07-04 13:47:45 UTC
Here is the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232370000 (LWP 8631)]
[KCrash handler]
#6  0x08058e68 in QString::operator+= ()
#7  0x08074160 in ?? ()
#8  0xbfba2ce0 in ?? ()
#9  0xbfba2bf6 in ?? ()
#10 0x00000004 in ?? ()
#11 0x08079b7d in ?? ()
#12 0xbfba2cec in ?? ()
#13 0xbfba2be4 in ?? ()
#14 0x0000001e in ?? ()
#15 0x025c18ce in ?? ()
#16 0x08236a80 in ?? ()
#17 0xb71e8eee in ?? () from /usr/qt/3/lib/libqt-mt.so.3
#18 0x08237430 in ?? ()
#19 0xb71f5b6c in QLineEdit::text () from /usr/qt/3/lib/libqt-mt.so.3
#20 0x08074ebb in ?? ()
#21 0xbfba2ce0 in ?? ()
#22 0xbfba2cec in ?? ()
#23 0xbfba2ce4 in ?? ()
#24 0xbfba2ce8 in ?? ()
#25 0x00000020 in ?? ()
#26 0x00000000 in ?? ()
Comment 4 Philip Rodrigues 2007-07-13 22:25:12 UTC
Unfortunately the backtrace isn't very useful because your kde is built without debugging symbols, but you can find instructions for producing more detailed backtraces here:
http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 5 Peter Hedlund 2007-09-18 22:11:02 UTC
SVN commit 714140 by hedlund:

Fix handling of hints.
BUG:147503

 M  +11 -5     qaview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=714140