Bug 147227 - digiKam crash, I don't know why, but I have the bugreport
Summary: digiKam crash, I don't know why, but I have the bugreport
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Runtime (show other bugs)
Version: 0.9.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-26 05:59 UTC by Alexandre Racine
Modified: 2022-01-23 11:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments
crash report (7.63 KB, text/plain)
2007-06-26 06:00 UTC, Alexandre Racine
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Racine 2007-06-26 05:59:44 UTC
Version:           0.9.1 (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-16-386

Not much to say about it. I was looking at pictures, when to the end, continue to look at the picture with the "back" button and crash. I'll attach the bugreport.
Comment 1 Alexandre Racine 2007-06-26 06:00:36 UTC
Created attachment 20962 [details]
crash report
Comment 2 Alexandre Racine 2007-06-26 06:01:23 UTC
Oups, sorry, this is a CRASH report and not a bug repost. Can you change it? Thanks.
Comment 3 Arnd Baecker 2007-06-26 09:35:03 UTC
What did you do precisely: e.g., did you look at the images in the imge-editor, 
or in the album view (in F3 mode)?
Can you reproduce the problem every time?

(Of course you might also think of upgrading to  0.9.2 ...)
Comment 4 caulier.gilles 2007-06-26 09:44:47 UTC
Arnd,

Look like the backtrace is uncomplete. It sound like the crash do not occurs in digiKam but outside. The last way where the trace give information is a method to set Rating of image. I suspect than Alexandre have changed somthing in Comments & Tags side bar (or something like that)... and save these informations into image metadata...

Well, i suspect a crash in Exiv2 (another one)...

Alexandre, I recommend to use :

Digikam 0.9.2
Exiv2 0.14           // Very important
libkexiv2 0.1.5      // Very important

You will need too libkdcraw 0.1.1

If you cannot update digiKam to 0.9.2, at least update Exiv2 and libkexiv2.

But in all case, if you compile yourself source code, please enable debug informations everywhere (./configure --enable-debug=full)

Question : witch Exiv2 release you use ?

Gilles Caulier

Comment 5 Alexandre Racine 2007-06-26 14:16:22 UTC
Ok, I have upgraded to 0.9.2 and if I can crash again, I'll fill another crash report.