Bug 147073 - Digikam: Import videos to seperate folder
Summary: Digikam: Import videos to seperate folder
Status: CLOSED NOT A BUG
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 0.9.1
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-22 08:31 UTC by Dotan Cohen
Modified: 2017-08-16 09:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2007-06-22 08:31:01 UTC
Version:           0.9.1 (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
OS:                Linux

I don't want my videos to be stored with my photos. An option to have the import wizard move videos to a seperate folder would help a lot.

Additionally, it often happens that I'm browsing photos in view mode (not thumbnail) when I stumble upon a video. The sudden sound emitted from the computer is rather startling, especially as the computer is used for music management and is connected to the speakers in the next room. If the videos were in a separate folder this would not happen.

Thanks.
Comment 1 caulier.gilles 2007-06-22 08:49:19 UTC
Dotan,

Camera interface can already done this job...

Gilles Caulier
Comment 2 Mikolaj Machowski 2007-06-22 09:34:25 UTC
1. When importing elements from camera you can store them in directories 
depending on extension. IMO this part of your report is INVALID.
2. Remark about playing of videos is important though. I think Digikam 
shouldn't play videos automatically.

----------------------------------------------------
Wroc
Comment 3 Arnd Baecker 2007-06-22 09:47:41 UTC
Ad 2.) *Maybe* this should be made configurable?

I.e.: Either play the video automatically, or
just display the first frame (and on click play the video)?
Comment 4 caulier.gilles 2007-06-22 09:49:05 UTC
Mik,

1/ Agree. If Dotan speak about Album/import option and not Camera gui, this is relevant of future common interface to do to import files from folder _or_ camera, based on camera gui. This pint has already reported in B.K.O in the pass by you... This is planed with after KDE4 port. Look entry #131407.

2/ This is already the case in Preview mode if you install properlly all KDE video service (this is what digiKam use). The only point where video are not supported is about native Slideshow tool witch only display pictures.

I tag this entry as invalid.

Gilles
Comment 5 Dotan Cohen 2007-07-06 11:53:17 UTC
Gilles, where in the Camera Interface can this be set? I still have 0.9.1 installed, but I don't see anywhere online a mention of the feature being added in 0.9.2. Note that the full changelog does not appear to be available online. It should be made available, specifically for instances like this.

My Fuji FinePix 5500 is detected as a Mass Storage Camera. Might this be the reason that I cannot set the file extension filters? In my opinion, the option should be in the Download From Camera dialog.
Comment 6 caulier.gilles 2007-07-06 12:02:39 UTC
> Note that the full changelog does not appear to be available online.

It is... look websvn interface : 

http://websvn.kde.org/branches/extragear/kde3/graphics/digikam/ChangeLog?revision=675050&view=markup

>My Fuji FinePix 5500 is detected as a Mass Storage Camera. Might this be the >reason that I cannot set the file extension filters?

no...

>In my opinion, the option should be in the Download From Camera dialog.

It is... 

http://digikam3rdparty.free.fr/Screenshots/CameraGUI_fileext_based_album_creation.png

Gilles
Comment 7 Arnd Baecker 2007-07-06 12:06:52 UTC
For the ChangeLog see here
http://websvn.kde.org/branches/extragear/kde3/graphics/digikam/ChangeLog
Comment 8 Dotan Cohen 2007-07-07 18:46:52 UTC
I must be dense, Arnd, because:
1) I was expecting a Changelog (or a list of what's new/changed) to be in an easily-accessible place from the Digikam.org website.
2) Even by following that link, and links on that page, I cannot find where it says anything along the lines of "New import option: Seperate files based on file extension". And that's when I'm actively looking for it. If someone wants to browse the changes, then he's out of luck. Is there no end-user version of the Changelog?
Comment 9 caulier.gilles 2007-07-08 22:39:26 UTC
Dotan,

For each release of digiKam, you can find a resume of new features implemented and all bugs report fixed in NEWS files available in tarballs.

For each release, these informations are post in announce and in web project site.

The digiKam page available in apps-kde.org conatins also these resumes :

http://www.kde-apps.org/content/show.php/digiKam?content=9957

Because the features that you want is already implemented in Camera GUI, i close this file...

Gilles Caulier
Comment 10 Dotan Cohen 2007-07-09 16:34:00 UTC
I don't mean to argue, Gilles, but I _still_ see no mention of the new feature to filter on file extension. The only mention of it in the tarball's Changelog is "when we create sub-albums based on file extensions, group same file extension together", and there is no mention of it on the digikam or kde-look websites.

I'm not trying to be a pain, but this is obviously a feature that was worked hard on, and here I am requesting it because although much effort was put into the feature, no mention of it is available. I wonder what other features there are that no mention is made of.

In any case, thanks for your hard efforts. I enjoy digikam and appreciate all the hard work that you do.