Bug 146973 - crashes when clicking on preview image
Summary: crashes when clicking on preview image
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-19 20:07 UTC by Mark Purcell
Modified: 2012-08-09 07:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.9.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Purcell 2007-06-19 20:07:11 UTC
Version:           0.9.2-final (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.21-1-686

This is a forwarded report from:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=418251, and
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=425169

I have had two users report digikam crashes evertime a preview image is selected, he confirms he is using exiv2 0.14 with the recent jpeg/tiff patches and this problem occurs with digikam 0.9.1 and 0.9.2.

I have loaded a sample image locally and the crash is not reproducible.

It maybe nvidia graphics related?

Mark

From: Don <don446@noark.net>

From: Christian Schult <cschult@gmx.de>
Date: Sun, 08 Apr 2007 16:26:23 +0200

Package: digikam
Version: 2:0.9.1-2

Everytime selecting an preview image to display it digikam crashes instantly
with SIGABRT. KDE-Backtrace shows:

(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xb5c3f947 in raise () from /lib/tls/libc.so.6
#6  0xb5c410c9 in abort () from /lib/tls/libc.so.6
#7  0xb5c3905f in __assert_fail () from /lib/tls/libc.so.6
#8  0xb5f329a2 in pthread_create@@GLIBC_2.1 () from /lib/tls/libpthread.so.0
#9  0xb6455068 in QThread::start () from /usr/lib/libqt-mt.so.3
#10 0xb6455107 in QThread::start () from /usr/lib/libqt-mt.so.3
#11 0xb7e314fa in Digikam::LoadSaveThread::LoadSaveThread () from /usr/lib/libdigikam.so.0
#12 0xb7e31582 in Digikam::ManagedLoadSaveThread::ManagedLoadSaveThread () from /usr/lib/libdigikam.so.0
#13 0xb7e315d2 in Digikam::PreviewLoadThread::PreviewLoadThread () from /usr/lib/libdigikam.so.0
#14 0xb7cfaf49 in Digikam::ImagePreviewWidget::setImagePath () from /usr/lib/libdigikam.so.0
#15 0xb7d330d4 in Digikam::ImagePreviewView::setImageInfo () from /usr/lib/libdigikam.so.0
#16 0xb7d3a80f in Digikam::AlbumWidgetStack::setPreviewItem () from /usr/lib/libdigikam.so.0
#17 0xb7d3ac5e in Digikam::DigikamView::slotTogglePreviewMode () from /usr/lib/libdigikam.so.0
#18 0xb7d42eba in Digikam::DigikamView::qt_invoke () from /usr/lib/libdigikam.so.0
#19 0xb64c4d4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0xb7cb92de in Digikam::AlbumIconView::signalPreviewItem () from /usr/lib/libdigikam.so.0
#21 0xb7d2f0b1 in Digikam::AlbumIconView::slotDoubleClicked () from /usr/lib/libdigikam.so.0
#22 0xb7d43a4f in Digikam::AlbumIconView::qt_invoke () from /usr/lib/libdigikam.so.0
#23 0xb64c4d4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#24 0xb7cc23f1 in Digikam::IconView::signalDoubleClicked () from /usr/lib/libdigikam.so.0
#25 0xb7cc5c5e in Digikam::IconView::itemClickedToOpen () from /usr/lib/libdigikam.so.0
#26 0xb7cc5edd in Digikam::IconView::contentsMouseReleaseEvent () from /usr/lib/libdigikam.so.0
#27 0xb65f8e51 in QScrollView::viewportMouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#28 0xb65fa3de in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#29 0xb64c4302 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#30 0xb64c4380 in QObject::event () from /usr/lib/libqt-mt.so.3
#31 0xb64fb612 in QWidget::event () from /usr/lib/libqt-mt.so.3
#32 0xb645cc26 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#33 0xb645edc9 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#34 0xb6bf8e0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0xb63f0495 in QApplication::sendSpontaneousEvent () from /usr/lib/libqt-mt.so.3
#36 0xb63ef12f in QETWidget::translateMouseEvent () from /usr/lib/libqt-mt.so.3
#37 0xb63ed6b0 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#38 0xb6403d02 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#39 0xb6477179 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#40 0xb6476f9a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#41 0xb645e7bf in QApplication::exec () from /usr/lib/libqt-mt.so.3
#42 0x0804ac89 in main ()
Comment 1 caulier.gilles 2007-08-24 22:34:46 UTC
Marcel,

Look like the backtrace crash under Digikam::LoadSaveThread::LoadSaveThread().

Are you any suggestions ?

Gilles Caulier



Comment 2 Marcel Wiesweg 2007-08-25 11:48:37 UTC
This is an abort from within glibc, when QThread::start() from the constructor of LoadSaveThread. The call from the constructor rules out that the object is null.
This might be a problem with Qt/glibc threading. It would be interesting if the other threaded operations (loading in image editor, histogram loading) work.
I think glibc usually gives some output on the console when it aborts?
Comment 3 caulier.gilles 2007-11-28 16:28:19 UTC
Mark,

Can you reproduce the crash to run digiKam from a console and post all text message here ?

Thanks in advance

Gilles Caulier
Comment 4 caulier.gilles 2008-03-19 07:56:03 UTC
Mark,

PLease update to last stable 0.9.3 and look if the problem still exist on your computer... Thanks in advance

Gilles Caulier
Comment 5 Arnd Baecker 2008-04-10 11:53:31 UTC
Closing this bug now.
This does not mean it is invalid by itself, but
without updated information (with full debug gdb backtrace)
using the current 0.9.3 version (or current svn)
it is not possible to find the root of the problem.

Please feel free to re-open if there is any new information.

Thanks a lot for your understanding,

Arnd

Comment 6 Mark Purcell 2008-07-12 11:57:06 UTC
Hi,

Upstream have closed your bug report as they are unable to reproduce.

If you are able to provide any further information then please follow the link below to the KDE report and add your comments.

Mark

-original message-
Subject: [Bug 146973] crashes when clicking on preview image   
From: Arnd Baecker <arnd.baecker@web.de>
Date: 22/04/2008 10:32

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=146973         
arnd.baecker web de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|                            |WORKSFORME



------- Additional Comments From arnd.baecker web de  2008-04-10 11:53 -------
Closing this bug now.
This does not mean it is invalid by itself, but
without updated information (with full debug gdb backtrace)
using the current 0.9.3 version (or current svn)
it is not possible to find the root of the problem.

Please feel free to re-open if there is any new information.

Thanks a lot for your understanding,

Arnd