Bug 146700 - Crash when burning audio CD
Summary: Crash when burning audio CD
Status: RESOLVED UNMAINTAINED
Alias: None
Product: k3b
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-12 15:21 UTC by Quinten
Modified: 2009-05-23 04:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (5.30 KB, application/octet-stream)
2007-06-12 15:22 UTC, Quinten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Quinten 2007-06-12 15:21:28 UTC
Version:           1.0.1 (using KDE KDE 3.5.7)
Installed from:    Compiled From Sources
Compiler:          gcc (GCC) 4.1.2 20061115 (prerelease) (SUSE Linux) 
OS:                Linux

I wanted to create an audio CD. I had tried it a few time before, but it gave errors about the burning speed. When I tried it again, k3b crashed.
Comment 1 Quinten 2007-06-12 15:22:11 UTC
Created attachment 20841 [details]
Backtrace

This is the backtrace.
Comment 2 Bram Schoenmakers 2007-06-12 19:40:55 UTC
Systeemconfiguratie opstartcontrole uitgeschakeld.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1234176304 (LWP 4665)]
[New Thread -1240953968 (LWP 4910)]
0xb7ef9410 in ?? ()
#0  0xb7ef9410 in ?? ()
#1  0xbffe79a8 in ?? ()
#2  0x00000008 in ?? ()
#3  0x0824b5e8 in ?? ()
#4  0xb6aa902b in __read_nocancel () from /lib/libpthread.so.0
#5  0xb739e8ae in _kde_IceTransSocketRead () from /opt/kde3/lib/libDCOP.so.4
#6  0xb739e57f in _kde_IceTransRead () from /opt/kde3/lib/libDCOP.so.4
#7  0xb739800f in _kde_IceRead () from /opt/kde3/lib/libDCOP.so.4
#8  0xb739cbcf in KDE_IceProcessMessages () from /opt/kde3/lib/libDCOP.so.4
#9  0xb7388419 in DCOPClient::callInternal () from /opt/kde3/lib/libDCOP.so.4
#10 0xb73886fd in DCOPClient::callInternal () from /opt/kde3/lib/libDCOP.so.4
#11 0xb738d147 in DCOPClient::call () from /opt/kde3/lib/libDCOP.so.4
#12 0xb738d1a7 in DCOPClient::call () from /opt/kde3/lib/libDCOP.so.4
#13 0xb738d3a8 in DCOPClient::disconnectDCOPSignal ()
   from /opt/kde3/lib/libDCOP.so.4
#14 0xb738dd19 in DCOPObject::~DCOPObject () from /opt/kde3/lib/libDCOP.so.4
#15 0xb7aaabf7 in KDirListerCache::~KDirListerCache ()
   from /opt/kde3/lib/libkio.so.4
#16 0xb7a9f164 in __tcf_26 () from /opt/kde3/lib/libkio.so.4
#17 0xb672ded1 in __cxa_finalize () from /lib/libc.so.6
#18 0xb79e6213 in __do_global_dtors_aux () from /opt/kde3/lib/libkio.so.4
#19 0xb7beee2c in _fini () from /opt/kde3/lib/libkio.so.4
#20 0xb7f08a4f in _dl_fini () from /lib/ld-linux.so.2
#21 0xb672dbcd in exit () from /lib/libc.so.6
#22 0xb6da8d22 in qt_xio_errhandler () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb747571d in KApplication::xioErrhandler ()
   from /opt/kde3/lib/libkdecore.so.4
#24 0xb7475769 in kde_xio_errhandler () from /opt/kde3/lib/libkdecore.so.4
#25 0xb69ba4cd in _XIOError () from /usr/lib/libX11.so.6
#26 0xb69bc907 in _XEventsQueued () from /usr/lib/libX11.so.6
#27 0xb69ab5d2 in XPending () from /usr/lib/libX11.so.6
#28 0xb6dc7921 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6e2f7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x080b6663 in K3bJobProgressDialog::startJob ()
#31 0x08161c43 in K3bProjectBurnDialog::slotStartClicked ()
#32 0x0817bf8f in K3bAudioBurnDialog::slotStartClicked ()
#33 0x080c052e in K3bInteractionDialog::slotStartClickedInternal ()
#34 0x080c0b39 in K3bInteractionDialog::qt_invoke ()
#35 0x0815fb73 in K3bProjectBurnDialog::qt_invoke ()
#36 0x0817ca43 in K3bAudioBurnDialog::qt_invoke ()
#37 0xb6e77f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb6e78b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb71bab5c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb6f0bbfd in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb6eb0880 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb6e189c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb6e19909 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb755e1d2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#45 0xb6db7f57 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb6db70ff in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb6dc798a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb6e2f7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0x080c0398 in K3bInteractionDialog::exec ()
#50 0x0815fd82 in K3bProjectBurnDialog::execBurnDialog ()
#51 0x0815e846 in K3bView::slotBurn ()
#52 0x0815e4ae in K3bView::qt_invoke ()
#53 0x0813c836 in K3bAudioView::qt_invoke ()
#54 0xb6e77f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#55 0xb6e78b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#56 0xb7744239 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#57 0xb77828e2 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#58 0xb7782b3d in KAction::activate () from /opt/kde3/lib/libkdeui.so.4
#59 0xb784b240 in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#60 0xb6e77f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#61 0xb6e78b5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#62 0xb71bab5c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#63 0xb6f0bbfd in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#64 0xb6eb0880 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#65 0xb6e189c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#66 0xb6e19909 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#67 0xb755e1d2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#68 0xb6db7f57 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#69 0xb6db70ff in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#70 0xb6dc798a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#71 0xb6e2f7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#72 0xb6e2f686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#73 0xb6e1857f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#74 0x080a1ffd in main ()
Comment 3 Sebastian Trueg 2007-06-18 15:20:59 UTC
sadly I cannot make much of these backtraces. Could you maybe enable debugging symbols (--enable-debug=full) and recompile k3b?
Comment 4 Lubos Lunak 2008-07-21 16:22:52 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 5 Dario Andres 2009-05-23 04:53:54 UTC
DCOP -> UNMAINTAINED