Bug 146648 - Audio notification open file dialog has bug in default file filter
Summary: Audio notification open file dialog has bug in default file filter
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Anne-Marie Mahfouf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-10 22:11 UTC by Marius
Modified: 2007-09-25 13:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Proposed patch (747 bytes, patch)
2007-09-25 10:16 UTC, Juan Carlos Torres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius 2007-06-10 22:11:28 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Gentoo Packages

When adding a new/editing an appointment in korganizer and want to add a audio file to be played as the notification, the dialog that allows you to select which file to play has a bug in the default filter, the default filter is "Wav Files\n*.mp3|MP3 files\n*.*|" which obviously is wrong and results in no files being shown whatsoever. There seems to be some kind of parsing error.

The dialog in in New appointment -> reminder, advanced -> Audio -> folder icon
Comment 1 Terence Simpson 2007-09-25 02:25:30 UTC
I can confirm this in Kubuntu (Gutsy):
Ubuntu package version: 4:3.5.7enterprise20070907-0ubuntu3
Korganizer version: 3.5.6 (enterprise 0.20070907.709405)
Comment 2 Juan Carlos Torres 2007-09-25 10:16:14 UTC
Created attachment 21684 [details]
Proposed patch

Proposed patch. Tested to work on kdepim built fro SVN (branch) and Kubuntu
(using the packaging system).
Comment 3 Anne-Marie Mahfouf 2007-09-25 11:15:23 UTC
fixed in r716784, thanks Juan for the patch!
Now looking in kde4 to apply here as well.
Comment 4 Anne-Marie Mahfouf 2007-09-25 11:17:08 UTC
SVN commit 716784 by annma:

fix bug about adding an audio file for notification. Only .wav were detected.
Thanks to Juan Carlos Torres for the patch!
BUG=146648


 M  +1 -1      koeditoralarms_base.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=716784
Comment 5 Anne-Marie Mahfouf 2007-09-25 13:41:33 UTC
SVN commit 716851 by annma:

forward port of 146648
CCBUG=146648


 M  +1 -1      koeditoralarms_base.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=716851