Bug 146545 - Copy/Paste from OO.o Calc into KMail message crashes KMail
Summary: Copy/Paste from OO.o Calc into KMail message crashes KMail
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 147819 148883 149329 149423 149524 149762 158488 158901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-08 15:45 UTC by Richard Johnson
Modified: 2008-03-07 14:33 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Johnson 2007-06-08 15:45:38 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
OS:                Linux

KDE 3.5.7 (Kubuntu 7.04)
Reported in Mailone #117632 (https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/117632)

KMail crashes when I copy and paste from an OpenOffice.org Calc spreadsheet into an email message. In the past this would paste a .png file into the message. Note that using select and middle mouse button works by pasting the text only. This was reported on Launchpad with a full Apport crash report. The following are the crash backtraces for this:

------------------------
ProblemType: Crash
 Architecture: i386
 CrashCounter: 1
 Date: Tue May 29 11:36:32 2007
 DistroRelease: Ubuntu 7.04
 ExecutablePath: /usr/bin/kontact
 Package: kontact 4:3.5.7-0ubuntu1~feisty1
 PackageArchitecture: i386
 ProcCmdline: kontact
 ProcCwd: /home/mcanedo
 ProcEnviron:
  PATH=/home/mcanedo/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
  LANG=es_MX.UTF-8
  SHELL=/bin/bash
 Signal: 11
 SourcePackage: kdepim
 StacktraceTop:
  QWidgetResizeHandler::eventFilter ()
  QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
  QApplication::notify () from /usr/lib/libqt-mt.so.3
  KApplication::notify () from /usr/lib/libkdecore.so.4
  KMComposeWin::slotPaste () from /usr/lib/libkmailprivate.so
 Uname: Linux mcanedo-laptop 2.6.20-16-generic #2 SMP Wed May 23 01:46:23 UTC 2007 i686 GNU/Linux
 UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video
------------------------

http://launchpadlibrarian.net/7871749/CoreDump.gz
http://launchpadlibrarian.net/7871750/Dependencies.txt
http://launchpadlibrarian.net/7871751/Disassembly.txt
http://launchpadlibrarian.net/7871752/ProcMaps.txt
http://launchpadlibrarian.net/7871753/ProcStatus.txt
http://launchpadlibrarian.net/7871754/Registers.txt
http://launchpadlibrarian.net/7871755/Stacktrace.txt
http://launchpadlibrarian.net/7871756/ThreadStacktrace.txt
http://launchpadlibrarian.net/7873457/<fdopen>
http://launchpadlibrarian.net/7873458/<fdopen>

========================

This crash was also verified by a Gentoo AMD64 user in #kde on IRC.
Comment 1 Thomas McGuire 2007-06-09 14:46:06 UTC
Confirmed.
This seems to be an infinite recursion.
Comment 2 Thomas McGuire 2007-07-12 20:16:18 UTC
*** Bug 147819 has been marked as a duplicate of this bug. ***
Comment 3 Thomas McGuire 2007-08-16 18:17:36 UTC
*** Bug 148883 has been marked as a duplicate of this bug. ***
Comment 4 Will Stephenson 2007-08-22 18:26:29 UTC
Yeah, it is an infinite recursion.  KMComposeWin::slotPaste(), if the pasted item is not image/png and not plain text, gets called recursively until the stack blows.

See https://bugzilla.novell.com/show_bug.cgi?id=302067 also
Comment 5 Thomas McGuire 2007-08-30 18:29:09 UTC
*** Bug 149329 has been marked as a duplicate of this bug. ***
Comment 6 Thomas McGuire 2007-08-30 19:00:14 UTC
Seems to be fixed by:

>SVN commit 706490 by tilladam:

>Forward port of:

>SVN commit 706484 by tilladam:

>Change nasty hack causing re-entrancy when pasting and thus tight loops with >clean delegation.
>Fixed kolab/issue1923.
Comment 7 Roger Foss 2007-08-31 09:44:26 UTC
Thanks.
I was struggling with trying to produce a crash report, but even after I
followed the FAQ on that and installed the -dbg packages the backtrace
option never showed up.

Good to see it is fixed, though.

Roger

On 2007-08-30 19:00, Thomas McGuire <Thomas.McGuire@gmx.net> wrote:

[bugs.kde.org quoted mail]

>>----------------------------------------------------------------------------
>Status|NEW |RESOLVED
>Resolution| |FIXED
>
>
>
>------- Additional Comments From Thomas.McGuire gmx net 2007-08-30
>19:00 -------
>Seems to be fixed by:
>
>>SVN commit 706490 by tilladam:
>
>>Forward port of:
>
>>SVN commit 706484 by tilladam:
>
>>Change nasty hack causing re-entrancy when pasting and thus tight
>>loops with >clean delegation.
>>Fixed kolab/issue1923.

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
 <meta name="generator" content="SuSE Linux Openexchange Server 4">
 <title></title>
</head>
<body>
Thanks.<br>I was struggling with trying to produce a crash report, but even after I followed the FAQ on that and installed the -dbg packages the backtrace option never showed up.<br><br>Good to see it is fixed, though.<br><br>Roger<br><br>On 2007-08-30 19:00, Thomas McGuire &lt;Thomas.McGuire@gmx.net&gt; wrote:<br><br>&gt; ------- You are receiving this mail because: -------<br>&gt; You are on the CC list for the bug, or are watching someone who is.<br>&gt;          <br>&gt; http://bugs.kde.org/show_bug.cgi?id=146545         <br>&gt; Thomas.McGuire gmx net changed:<br>&gt; <br>&gt;            What    |Removed                     |Added<br>&gt; ----------------------------------------------------------------------------<br>&gt;              Status|NEW                         |RESOLVED<br>&gt;          Resolution|                            |FIXED<br>&gt; <br>&gt; <br>&gt; <br>&gt; ------- Additional Comments From Thomas.McGuire gmx net  2007-08-30 19:00 -------<br>&gt; Seems to be fixed by:<br>&gt; <br>&gt; &gt;SVN commit 706490 by tilladam:<br>&gt; <br>&gt; &gt;Forward port of:<br>&gt; <br>&gt; &gt;SVN commit 706484 by tilladam:<br>&gt; <br>&gt; &gt;Change nasty hack causing re-entrancy when pasting and thus tight loops with &gt;clean delegation.<br>&gt; &gt;Fixed kolab/issue1923.<br>


</body>
</html>
Comment 8 Thomas McGuire 2007-08-31 15:30:52 UTC
*** Bug 149423 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2007-09-03 19:42:24 UTC
*** Bug 149524 has been marked as a duplicate of this bug. ***
Comment 10 Matteo Croce 2007-09-04 00:02:52 UTC
Crashes here even while pasting plain text
Comment 11 Thomas McGuire 2007-09-11 17:28:05 UTC
*** Bug 149762 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2008-02-27 19:30:15 UTC
*** Bug 158488 has been marked as a duplicate of this bug. ***
Comment 13 Thomas McGuire 2008-03-07 14:33:52 UTC
*** Bug 158901 has been marked as a duplicate of this bug. ***