Bug 146423 - klipper shouldnt ask user whether it should start on login when user quits it
Summary: klipper shouldnt ask user whether it should start on login when user quits it
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: LO normal with 1 vote (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
: 83039 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-05 20:55 UTC by Olivier Vitrat
Modified: 2021-04-01 20:32 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Vitrat 2007-06-05 20:55:31 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Debian testing/unstable Packages

Reoprted in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=427431

If you click on klipper and choose "quit," klipper asks you if you want klipper to start when the user logs in.  This is intuitive if klipper is already starting on login, and you want it to stop doing so.

However, quitting klipper is also the only way (as far as I can tell) to ask klipper to begin starting on login when it isn't already doing so.  It's unintuitive to ask a program to run by quitting it.
Comment 1 Maciej Pilichowski 2008-02-07 22:56:55 UTC
Totally agree.
a) humours argument -- it is like Windows start but in reverse
but seriously
b) user wants to quit, nothing else -- why all of the sudden user has to answer what to do with start
c) if user (like me) has properly configured klipper -- she/he does not want to change anything, so why questioning user
d) it is completely unclear what mechanism klipper will turn on -- maybe user has a link for autostart, maybe it is configured via autostart, maybe it was run manually, maybe it was run automatically by restoring session

If user wants to quit -- quit. 

( I ended with running klipper despite I have to run memory-hungry program, I didn't quit because I don't know what klipper would do on "start" or "do not start" ).
Comment 2 Maciej Pilichowski 2008-02-07 23:01:48 UTC
Strictly related report:
https://bugs.kde.org/show_bug.cgi?id=137925

but let's keep it separate (open) since the other one was FIXED but only for quit confirmation.
Comment 3 Dmitry Suzdalev 2008-11-26 09:24:04 UTC
*** Bug 83039 has been marked as a duplicate of this bug. ***
Comment 4 Jakob Lehmann 2010-01-19 03:55:03 UTC
Confirmed in KDE SC 4.3.90.
Comment 5 Esben Mose Hansen 2010-01-19 09:18:54 UTC
I agree, as always, that it is a silly way to handle it, but it is hardly a major issue. I plan to fix this, among other stuff, for 4.5.
Comment 6 Jekyll Wu 2011-12-24 20:03:57 UTC
OK, it seems everyone agrees the 'asking for autostart or not when quitting' behavior is strange. It is more logical to put it into the configure dialog.

But, I just wonder: Why(or since when) does klipper provide the option for controlling its autostart? The existence of that option implies something to me: many or enough users do not use or like klipper at all, so they want to disable its autostart. 

Personally, I think klipper should either remove that option and always autostart, or change its installation script to not autostart by default and let users control its autostart through the kcm_autostart module . The current state seems self contradiction to me.
Comment 7 Nate Graham 2021-04-01 20:32:30 UTC
No longer relevant since Klipper is now integrated into Plasma and isn't a standalone app.