Bug 145907 - boxes around links / hyperrefs are printed
Summary: boxes around links / hyperrefs are printed
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-24 17:13 UTC by florian
Modified: 2007-12-08 22:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
small pdf showing the problem. (9.24 KB, application/pdf)
2007-05-24 19:23 UTC, florian
Details
screenshot showing the rectangles (11.79 KB, image/png)
2007-05-24 19:25 UTC, florian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description florian 2007-05-24 17:13:16 UTC
Version:           0.5.7 (using KDE KDE 3.5.7)
Installed from:    Unlisted Binary Package
OS:                Linux

Since the upgrade to KDE 3.5.7 (Archlinux) KPdf prints boxes around links (hyperrefs).
As they aren't visible otherwise I suppose a flag has been inverted...
They probably should show up on Screen, but not during print.
Comment 1 Albert Astals Cid 2007-05-24 19:11:41 UTC
Can not reproduce, can you attach a pdf with which you are having this problem?
Comment 2 florian 2007-05-24 19:23:58 UTC
Created attachment 20687 [details]
small pdf showing the problem.

in normal mode the footnote does not have any rectangle.
in print mode it has.
Comment 3 florian 2007-05-24 19:25:15 UTC
Created attachment 20688 [details]
screenshot showing the rectangles

this screenshot shows the bug: the top view is the normal view. There is no
rectangle. The bottom is the print-preview. There is a red rectangle. (which
is then printed).
Comment 4 Albert Astals Cid 2007-05-25 20:36:30 UTC
SVN commit 668258 by aacid:

changing APIs means you should TRIPLE check, double checking is not enough :-/
BUGS: 145907


 M  +3 -3      generator_pdf.cpp  


--- branches/KDE/3.5/kdegraphics/kpdf/core/generator_pdf/generator_pdf.cpp #668257:668258
@@ -316,7 +316,7 @@
     // 1. Set OutputDev parameters and Generate contents
     // note: thread safety is set on 'false' for the GUI (this) thread
     kpdfOutputDev->setParams( request->width, request->height, genObjectRects, genObjectRects, false );
-    pdfdoc->displayPage( kpdfOutputDev, page->number() + 1, fakeDpiX, fakeDpiY, 0, false, true, genObjectRects );
+    pdfdoc->displayPage( kpdfOutputDev, page->number() + 1, fakeDpiX, fakeDpiY, 0, false, true, false );
     if ( genObjectRects )
         pdfdoc->processLinks( kpdfOutputDev, page->number() + 1 );
 
@@ -498,7 +498,7 @@
         docLock.lock();
         for ( ; pIt != pEnd; ++pIt )
         {
-            pdfdoc->displayPage(psOut, *pIt, 72, 72, 0, false, globalParams->getPSCrop(), gFalse);
+            pdfdoc->displayPage(psOut, *pIt, 72, 72, 0, false, globalParams->getPSCrop(), gTrue);
         }
         docLock.unlock();
 
@@ -1197,7 +1197,7 @@
     d->generator->kpdfOutputDev->setParams( width, height, 
                                             genObjectRects, genObjectRects, TRUE /*thread safety*/ );
     d->generator->pdfdoc->displayPage( d->generator->kpdfOutputDev, page->number() + 1,
-                                       fakeDpiX, fakeDpiY, 0, false, true, genObjectRects );
+                                       fakeDpiX, fakeDpiY, 0, false, true, false );
     if ( genObjectRects )
         d->generator->pdfdoc->processLinks( d->generator->kpdfOutputDev, page->number() + 1 );
 
Comment 5 Michael Ummels 2007-10-31 13:35:49 UTC
I don't think this bug has been fixed. With KPDF 0.5.8 I still have the problem.
Comment 6 florian 2007-10-31 14:01:30 UTC
I just tested on some examples, and for me the problem is gone. Does the bug happen with the attached pdf? If not, please upload a sample pdf. If yes, do you see the borders in the print-preview too?
Comment 7 Eddy Flas 2007-12-08 22:19:46 UTC
I still have the problem here.
My version of kpdf is 0.5.8 provided by Kubuntu (package version 4:3.5.8-0ubuntu1).
Could it be still present in Kubuntu because Kubuntu uses a different kpdf from the official one (something to do with poppler) ?
Comment 8 Albert Astals Cid 2007-12-08 22:43:52 UTC
If you are seeing a red square it is working.