Bug 145870 - Kmail filters have stopped working with an IMAP server
Summary: Kmail filters have stopped working with an IMAP server
Status: RESOLVED DUPLICATE of bug 126182
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-23 20:03 UTC by Mike Coan
Modified: 2007-05-25 20:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Coan 2007-05-23 20:03:19 UTC
Version:           1.2.5 (using KDE 3.5.7 "release 10.1" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.18.8-0.3-default

I recently upgraded to KDE 3.5.7 using the rpms for OpenSuse 10.2 (x86_64 version).  I connect to an IMAP server.  all messages now remain in the inbox and are not filtered into the proper folders.  If I press Ctl-J on an individual message it is filtered to the proper folder.  If I highlight a group of messages and press Ctl-J, only 1 message is moved.  All other messages remain in the inbox, but have a line through them.  To remove the line and use the inbox I need to move to another folder and then return to inbox.

Previously when the filters stopped working I would close Kontact and restart it and the filters would be fine.  Nothing I have tried gets the filters working, other than pressing Ctl-J message by message.

Thsi began as soon as I upgrded to kde 3.5.7 using the rpms found on the OpenSuse buildservice
Comment 1 Ingo Klöcker 2007-05-23 21:07:33 UTC
Update again. This bug has already been fixed in the OpenSuse packages.
Comment 2 Ingo Klöcker 2007-05-24 00:32:02 UTC
Also see http://lists.kde.org/?t=117881133300002
Comment 3 Mike Coan 2007-05-24 18:14:45 UTC
I am sorry but there is no additional update for the openSuSE packages.  I am getting the rpms from 
http://software.opensuse.org/download/KDE:/KDE3/openSUSE_10.2/x86_64/

The file is kdepim3-3.5.7-7.1-x86_64.rpm  dated May 18, 2007.  I even reinstalled that package.  No difference.  I checked the thread mentioned in Additional comment #2, but my problem is not that kmail leaves the messages in the inbox after filtering, but that it does not move the messages from inbox to the correct folder.  My filters are from the IMAP inbox to other IMAP folders, with no messages in local folders.

Since other people don't have this problem it must be an openSuSE problem.  i will ask there as well.
Comment 4 Mike Coan 2007-05-24 21:35:22 UTC
See my comment #3 above.  I forgot to reopen the bug when I submitted that comment.  Comment #1 indicates the bug has been fixed in the openSUSE packages.  I have the packages dated 5-18-07, but the problem remains. If I am missing something I apologize.
Comment 5 Thomas McGuire 2007-05-25 20:40:53 UTC
You are not missing something, the bug fixed in the openSuse packages is another one.

The bug you have reported seems to be another case of bug 126182, which for some reason seems to happen more often in 1.9.7.
Therefore I'll close this as a duplicate.

*** This bug has been marked as a duplicate of 126182 ***