Bug 145819 - Filters don't match after upgrade to 1.9.7 / KDE 3.5.7
Summary: Filters don't match after upgrade to 1.9.7 / KDE 3.5.7
Status: RESOLVED DUPLICATE of bug 126182
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.7
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-22 21:29 UTC by Gabriel Ambuehl
Modified: 2007-05-24 17:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Ambuehl 2007-05-22 21:29:49 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages
OS:                Linux

After upgrading to Kubuntu KDE 3.5.7 packages (containing kmail 1.9.7) mail filters don't work reliably anymore.

For example, I have the following:

[Filter #0]
Applicability=0
AutomaticName=false
ConfigureShortcut=true
ConfigureToolbar=false
Icon=
StopProcessingHere=true
accounts-set=
action-args-0=trash
action-name-0=transfer
actions=1
apply-on=check-mail,manual-filtering
contentsA=Y
fieldA=X-Spam-Flag
funcA=contains
name=<X-Spam-Flag>: YES
operator=and
rules=1

but even though I have plenty of mails that spamassassin did flag as spam, it doesn't match.
Comment 1 Thomas McGuire 2007-05-22 21:45:01 UTC
Spamassassin actually adds a X-Spam-Status header, not X-Spam-Flag. 
Can you check if maybe this was your error?
I tried with X-Spam-Status contains 'yes' and that works for me.
Comment 2 Gabriel Ambuehl 2007-05-23 07:06:51 UTC
Actually, that filter worked just fine before the upgrade!

Here's a header excerpt from a message marked as spam:

X-Spam-Flag: YES
 X-Spam-Checker-Version: SpamAssassin 3.1.7-deb (2006-10-05) on buz-t60.lan
 X-Spam-Level: ****************
 X-Spam-Status: Yes, hits=16.6 required=7.5 tests=BAYES_99,EXTRA_MPART_TYPE,
      FORGED_RCVD_HELO,HTML_IMAGE_ONLY_08,HTML_MESSAGE,MY_CID_AND_STYLE,
      PART_CID_STOCK,PART_CID_STOCK_LESS,SARE_GIF_ATTACH,SARE_GIF_STOX,
      TVD_FW_GRAPHIC_ID1,UNPARSEABLE_RELAY autolearn=no version=3.1.7-deb

I can't figure out why it suddenly stopped working. I think some other filters still trigger, but don't move messages like they should.
Comment 3 Gabriel Ambuehl 2007-05-23 07:27:44 UTC
Going back to 1.9.6 as shipped in Kubuntu Feisty lets the very same filters work again, BTW.
Comment 4 Thomas McGuire 2007-05-23 18:09:44 UTC
Hmm, seems like spamassassin only adds the X-Spam-Flag header to mails which are spam, but the X-Spam-Status header to every mail.

Anyway, I added you filter to my kmailrc (without the check-mail part though) and tested. It works like it should. In KMail 1.9.7.

Are you perhaps using IMAP?
Does the filter work if you use "mark as important" instead of "move to trash" as action?
Comment 5 Sune Vuorela 2007-05-23 23:49:43 UTC
I think I have recieved this bug report in debian also.  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=425739
Comment 6 Daniel Hahler 2007-05-24 00:21:29 UTC
This is not related to Spamassassin/X-Spam.

Since 3.5.7 nearly all my mails are not filtered anymore, too.
See also bug 126182.
Comment 7 Gabriel Ambuehl 2007-05-24 07:05:03 UTC
I agree, it also happens on other filters, so it is NOT specific on 
SpamAssassin. Some filters still trigger, but subsequently fail to move the 
mails to the intended destination.
Comment 8 Thomas McGuire 2007-05-24 17:24:13 UTC
I will close this as a duplicate of bug 126182 then. Plenty of people who upgraded to 1.9.7 have already commented there, and it seems to be the same problem as here. Maybe the new version only triggers that bug more often.

*** This bug has been marked as a duplicate of 126182 ***