Bug 145514 - kopete crash on yahoo message (even at startup)
Summary: kopete crash on yahoo message (even at startup)
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: Yahoo Plugin (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 150366 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-16 17:53 UTC by Andriy Gapon
Modified: 2007-10-18 07:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
stack trace (no debugging) (2.16 KB, text/plain)
2007-05-16 17:54 UTC, Andriy Gapon
Details
kopete output before the crash (112.65 KB, text/plain)
2007-05-16 17:55 UTC, Andriy Gapon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Gapon 2007-05-16 17:53:41 UTC
Version:           kdenetwork-kopete-0.12.4 (using KDE KDE 3.5.6)
Installed from:    FreeBSD Ports
OS:                FreeBSD

my kopete crashed while I was away from my desk, after that it crashes at each start up attempt.
stack trace (no debugging) and kopete output will be attached.
Comment 1 Andriy Gapon 2007-05-16 17:54:58 UTC
Created attachment 20595 [details]
stack trace (no debugging)
Comment 2 Andriy Gapon 2007-05-16 17:55:46 UTC
Created attachment 20596 [details]
kopete output before the crash
Comment 3 Bram Schoenmakers 2007-05-16 22:47:38 UTC
[New Thread 0x5f3000 (LWP 100124)]
[Switching to Thread 0x5f3000 (LWP 100124)]
[KCrash handler]
#6  0x000000080695770c in YMSGProtocol::parse ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#7  0x000000080696c05f in CoreProtocol::wireToTransfer ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#8  0x000000080696c55c in CoreProtocol::addIncomingData ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#9  0x0000000806961779 in ClientStream::bs_readyRead ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#10 0x0000000806964ad2 in ClientStream::qt_invoke ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#11 0x0000000803d06da8 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#12 0x0000000803d07512 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#13 0x000000080695ed0b in KNetworkByteStream::slotReadyRead ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#14 0x000000080695edfc in KNetworkByteStream::qt_invoke ()
   from /usr/local/lib/kde3/kopete_yahoo.so
#15 0x0000000803d06da8 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#16 0x0000000803d07512 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#17 0x0000000802f894cd in KNetwork::KBufferedSocket::qt_invoke ()
   from /usr/local/lib/libkdecore.so.6
#18 0x0000000803d06da8 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#19 0x0000000803d073af in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#20 0x0000000803d1f62b in QSocketNotifier::event ()
   from /usr/X11R6/lib/libqt-mt.so.3
#21 0x0000000803cab98d in QApplication::internalNotify ()
   from /usr/X11R6/lib/libqt-mt.so.3
#22 0x0000000803cabd1e in QApplication::notify ()
   from /usr/X11R6/lib/libqt-mt.so.3
#23 0x0000000802e51a5a in KApplication::notify ()
   from /usr/local/lib/libkdecore.so.6
#24 0x0000000803ca0777 in QEventLoop::activateSocketNotifiers ()
   from /usr/X11R6/lib/libqt-mt.so.3
#25 0x0000000803c5f5b8 in QEventLoop::processEvents ()
   from /usr/X11R6/lib/libqt-mt.so.3
#26 0x0000000803cbfe09 in QEventLoop::enterLoop ()
   from /usr/X11R6/lib/libqt-mt.so.3
#27 0x0000000803cbfd62 in QEventLoop::exec ()
   from /usr/X11R6/lib/libqt-mt.so.3
#28 0x00000000004435d7 in main ()
Comment 4 Andre Duffeck 2007-09-29 14:26:23 UTC
SVN commit 718647 by duffeck:

Rewrite the code that parses the key-value pairs. That probably fixes #145514.
BUG:145514


 M  +12 -54    ymsgprotocol.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=718647
Comment 5 Andre Duffeck 2007-10-18 07:47:02 UTC
*** Bug 150366 has been marked as a duplicate of this bug. ***