Bug 144434 - search fails on IMAP and localhost
Summary: search fails on IMAP and localhost
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail
Classification: Applications
Component: search (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-19 23:05 UTC by Mats Ahlgren
Modified: 2007-07-03 00:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mats Ahlgren 2007-04-19 23:05:51 UTC
Version:           1.9.6 (using KDE 3.5.6 "release 64.1" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.20-rt8-default

query:
match all of {[body] [contains] ["krusader"]}
"Body" seems to trigger this behavior

Case 1:
Searching inbox of IMAP mailbox:
Result: Kmail says it's "0 messages searched so far" and doesn't do anything. No CPU is being used. This does not happen if I search headers.

Case 2:
Searching local folders only:
Result: KMail segfaults.
Comment 1 Mats Ahlgren 2007-04-19 23:06:19 UTC
Oh, this problem also happens with KMail 1.9.5.
Comment 2 Thomas McGuire 2007-04-20 12:36:58 UTC
>Result: KMail segfaults. 
Please provide a backtrace of this.
Comment 3 Bram Schoenmakers 2007-07-03 00:35:40 UTC
Without a backtrace there's not much we can do unfortunately. Please reopen if you have one.