Bug 143866 - kmail crash when creating index
Summary: kmail crash when creating index
Status: RESOLVED DUPLICATE of bug 108329
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-05 10:05 UTC by Ulrich Gemkow
Modified: 2007-04-05 10:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Gemkow 2007-04-05 10:05:36 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Compiled From Sources
Compiler:          gcc 4.1 
OS:                Linux

Following crash happens after deleting all index files (because of index corruption)

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1251543344 (LWP 2032)]
[KCrash handler]
#6  0xb7cf121e in KMFolderMbox::createIndexFromContents (this=0x8231448)
    at kmfoldermbox.cpp:664
#7  0xb7cf4b4b in KMFolderMbox::open (this=0x8231448) at kmfoldermbox.cpp:174
#8  0xb7dc7328 in KMFolderIndex::fillMessageDict (this=0x8231448)
    at kmfolderindex.cpp:466
#9  0xb7c6ef30 in FolderStorage::invalidateFolder (this=0x8231448)
    at folderstorage.cpp:941
#10 0xb7c6efb7 in FolderStorage::readFolderIdsFile (this=0x8231448)
    at folderstorage.cpp:929
#11 0xb7c6f010 in FolderStorage::registerWithMessageDict (this=0x8231448)
    at folderstorage.cpp:916
#12 0xb7c543cd in KMFolder (this=0x8231340, aParent=0x81f6e28, 
    aFolderName=@0xbfd89294, aFolderType=KMFolderTypeMbox, withIndex=true, 
    exportedSernums=true) at kmfolder.cpp:136
#13 0xb7c9007f in KMFolderDir::reload (this=0x81f6e28) at kmfolderdir.cpp:268
#14 0xb7c901fb in KMFolderDir::reload (this=0x81d228c) at kmfolderdir.cpp:283
#15 0xb7c93306 in KMFolderMgr::setBasePath (this=0x81d2260, 
    aBasePath=@0xbfd89518) at kmfoldermgr.cpp:165
#16 0xb7c93941 in KMFolderMgr (this=0x81d2260, aBasePath=@0xbfd89518, 
    dirType=KMStandardDir) at kmfoldermgr.cpp:42
#17 0xb7d2a2c5 in KMKernel::init (this=0xbfd89694) at kmkernel.cpp:1466
#18 0x0804a790 in main (argc=7, argv=0xbfd89854) at main.cpp:96
Comment 1 Tommi Tervo 2007-04-05 10:16:42 UTC

*** This bug has been marked as a duplicate of 108329 ***