Bug 143601 - Work Offline <-> Work Online icon should be 2 icons
Summary: Work Offline <-> Work Online icon should be 2 icons
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: keys and menus (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-29 19:55 UTC by Damir Perisa
Modified: 2008-01-27 18:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damir Perisa 2007-03-29 19:55:13 UTC
Version:           1.9.6 (using KDE 3.5.6, Arch Linux)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.20-ARCH

since bug 7765 implementation, there is a online state function in kmail. you can select to "work offline" when you want to let kmail know that it should not try to use any network.

this feature has a small (microscopic) bug: the icon that switches the state (when you add it to the toolbar) looks exactly the same for both states. it's always a globe connected with a wire. the problem is that you do not know on first sight if you are now in online or offline mode. 

it would help, make things nicer, to use two different icons... like it is done in kget online<->offline switch 

i want to stress, that this is a microscopic bug and should be the lowest priority possible ;)

thanx in advance
Comment 1 Damir Perisa 2007-03-29 19:57:15 UTC
sorry, if it sounds confusing... english is not my main language... what i mean is: the icon on the toolbar, if added, is only one... and if you press it, kmail switches state from offline to online... you press again, it switches back. the icon should resemble the state and change (maybe by removing the link of the globe to the wire for example)
Comment 2 Thomas McGuire 2008-01-27 18:34:44 UTC
In trunk, there are now 2 icons for this action.