Bug 143376 - Logitech Quickcam Pro 4000 webcam does not work anymore in kopete from KDE 3.5.6
Summary: Logitech Quickcam Pro 4000 webcam does not work anymore in kopete from KDE 3.5.6
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: Audio/Video Plugin (show other bugs)
Version: unspecified
Platform: Slackware Linux
: NOR normal with 180 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-23 05:43 UTC by Claudio Henrique Fortes Felix
Modified: 2007-06-21 09:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Henrique Fortes Felix 2007-03-23 05:43:08 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Slackware Packages
OS:                Linux

My webcam is not working anymore in kopete from KDE 3.5.6, although it used to work fine in some earlier KDE 3.5.x release (not sure if it was 3.5 itself or 3.5.4). It is a Logitech Quickcam Pro 4000, which is listed like this on lsusb:
Bus 1 Device 2: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000

One thing worth noting is that when it used to work, the screen from Settings... Configure... Devices... would show a "usb" text in the "input" drop down list. Now in KDE 3.5.6 it shows "Webcam" and no image shows up at all.

Based on bug 117682 explanation from Claudio da Silveira Pinheiro, I tried running kopete from the console with --noconnect and kept watching /var/log/debug.

As soon as kopete kicks in, I get this in the above logfile:
Mar 23 01:08:19 atlantis kernel:  usbdev1.2_ep82: ep_device_release called for usbdev1.2_ep82
Mar 23 01:08:19 atlantis kernel:  usbdev1.2_ep85: ep_device_release called for usbdev1.2_ep85
Mar 23 01:08:20 atlantis kernel: usb 1-2: kopete timed out on ep0in len=0/1

Then, when I choose Settings... Configure... Devices... from kopete menu, the webcam green led goes on and the following messages repeat on /var/log/debug, but no video comes out yet:
Mar 23 01:09:04 atlantis kernel:  usbdev1.2_ep82: ep_device_release called for usbdev1.2_ep82
Mar 23 01:09:04 atlantis kernel:  usbdev1.2_ep85: ep_device_release called for usbdev1.2_ep85

Any ideas? Thanks!
Comment 1 Giacomo Lozito 2007-03-28 15:58:51 UTC
I can confirm the regression.
Logitech quickcam pro 4000 worked in kopete 0.12.2 but doesn't work anymore in 0.12.4. Actually, I'm also unable to receive other people webcam as well with 0.12.4 (while everything worked nicely with 0.12.2).

For what is worth, the quickcam pro 4000 uses the pwc driver.
I've noticed that there's a opened bug for pwc (140528),
but I don't know if that is related.
Comment 2 Ronny Chilinski 2007-04-08 14:45:08 UTC
Same problem here with Kubuntu Feisty and kopete 0.12.4.
No video comes out.

In 0.12.3 video dont come out 1st time I started kopete. When i choose Settings -> Configure -> Devices twice, video works.

Webcam works in other programs like ekiga, camstream, camorama.
Comment 3 Jonas Kvinge 2007-04-11 20:02:21 UTC
Got the same problems. Back screen in Kopete when configuring the cam. The cam works in mplayer, I'm using 0.12.3 KDE 3.5.5 on openSUSE 10.2.
Comment 4 Giacomo Lozito 2007-04-19 17:05:30 UTC
I found a way to fix it for me,
by manually applying the patch (id=19393) from this bugreport:
http://bugs.kde.org/show_bug.cgi?id=140528

Basically I picked every VIDEO_PALETTE_YUV420 and changed it to VIDEO_PALETTE_YUV420P and recompiled
(there are three occurencies of the macro in libkopete/avdevice/videodevice.cpp , kopete 0.12.4).
Comment 5 Jonas Kvinge 2007-04-24 16:40:28 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Amicale Salmson 2007-05-09 16:27:59 UTC
I also compile version 0.12.2 and change VIDEO_PALETTE_YUV420 to VIDEO_PALETTE_YUV420P and it works fine now.
Comment 7 Ronny Chilinski 2007-05-09 16:38:45 UTC
Perhaps someone can build a .deb file so I dont have to compile it by myself.
Comment 8 Chuan-kai Lin 2007-05-12 00:24:24 UTC
Somebody should merge this bug with bug 140528 (or better yet, apply the patch and close both bugs!)
Comment 9 Jonas Kvinge 2007-05-21 21:00:28 UTC
Kopete does not work with cams using the R5U870 driver either, please see: http://lsb.blogdns.net/ry5u870/ . I also tested Kopete with a Creative NX webcam, and it had the same problems as the Logitech cam.
Comment 10 Guillaume Duveau 2007-06-01 00:50:54 UTC
I applied Chuan-kai's patch (http://bugs.kde.org/attachment.cgi?id=19393&action=view, see this bug : http://bugs.kde.org/show_bug.cgi?id=140528) and I compiled, now Kopete 0.12.4 from KDE 3.5.6 works very well with my Quickcam Zoom on my Ubuntu Feisty box (i386). Here's a .deb : http://guillaume.duveau.free.fr/public/f/deb/kopete_3.5.6-0ubuntu9_i386.deb

Could the Kopete developpers apply this patch to the code if it doesn't break any other things ?
Comment 11 Matt Rogers 2007-06-09 03:28:02 UTC
SVN commit 673109 by mattr:

fix bugs 140528 and 143376.

BUGS: 140528, 143376



 M  +4 -2      videodevice.cpp  


--- branches/KDE/3.5/kdenetwork/kopete/libkopete/avdevice/videodevice.cpp #673108:673109
@@ -1604,7 +1604,8 @@
 				case VIDEO_PALETTE_RGB32	: return PIXELFORMAT_RGB32;	break;
 				case VIDEO_PALETTE_YUYV		: return PIXELFORMAT_YUYV;	break;
 				case VIDEO_PALETTE_UYVY		: return PIXELFORMAT_UYVY;	break;
-				case VIDEO_PALETTE_YUV420	: return PIXELFORMAT_YUV420P;	break;
+				case VIDEO_PALETTE_YUV420	:
+				case VIDEO_PALETTE_YUV420P	: return PIXELFORMAT_YUV420P;	break;
 				case VIDEO_PALETTE_YUV422P	: return PIXELFORMAT_YUV422P;	break;
 			}
 			break;
@@ -1758,7 +1759,8 @@
 				case VIDEO_PALETTE_RGB32	: returnvalue = pixelFormatName(PIXELFORMAT_RGB32);	break;
 				case VIDEO_PALETTE_YUYV		: returnvalue = pixelFormatName(PIXELFORMAT_YUYV);	break;
 				case VIDEO_PALETTE_UYVY		: returnvalue = pixelFormatName(PIXELFORMAT_UYVY);	break;
-				case VIDEO_PALETTE_YUV420	: returnvalue = pixelFormatName(PIXELFORMAT_YUV420P);	break;
+				case VIDEO_PALETTE_YUV420	:
+				case VIDEO_PALETTE_YUV420P	: returnvalue = pixelFormatName(PIXELFORMAT_YUV420P);	break;
 				case VIDEO_PALETTE_YUV422P	: returnvalue = pixelFormatName(PIXELFORMAT_YUV422P);	break;
 			}
 			break;
Comment 12 Jon Cox 2007-06-21 09:35:18 UTC
I had same problem with Quickcam 3000 Pro. I installed the patched deb package and it fixed the problem for me as well.