Bug 143375 - kerry crashes when doing a search
Summary: kerry crashes when doing a search
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kerry
Classification: Unclassified
Component: general (show other bugs)
Version: 0.1
Platform: Ubuntu Packages Linux
: NOR crash with 10 votes (vote)
Target Milestone: ---
Assignee: Stephan Binner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-23 03:27 UTC by mailbinoyv
Modified: 2012-11-09 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mailbinoyv 2007-03-23 03:27:51 UTC
Version:           0.1 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
Compiler:          gcc 4.1.2 is what i get from gcc -v 
OS:                Linux

I recently had to move /usr/share/doc to a vfat partition because of disk space problems, not sure if its related to that. 
kerry crashes when I do a query (any query afaik). It used to work until recently. beagle-search works without problems. here's a backtrace

-----
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208482128 (LWP 14106)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x4105d0e2 in beagle_timestamp_to_unix_time ()
   from /usr/lib/libbeagle.so.0
#7  0x41027b20 in BeagleSearch::hits_added_cb ()
   from /usr/lib/libkdeinit_kerry.so
#8  0x4f51e039 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#9  0x4f51179b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#10 0x4f521b93 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#11 0x4f5230b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#12 0x4f523279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#13 0x41058588 in beagle_query_new () from /usr/lib/libbeagle.so.0
#14 0x4f51e039 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#15 0x4f50ffb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#16 0x4f51179b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#17 0x4f5221e3 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#18 0x4f5230b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#19 0x4f523279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#20 0x4105b770 in beagle_request_get_type () from /usr/lib/libbeagle.so.0
#21 0x4f3a6c8d in g_io_channel_unix_get_fd () from /usr/lib/libglib-2.0.so.0
#22 0x4f37d802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x4f3807df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#24 0x4f380b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#25 0x41027337 in BeagleSearch::search () from /usr/lib/libkdeinit_kerry.so
#26 0x4102e458 in SearchDlg::search () from /usr/lib/libkdeinit_kerry.so
#27 0x41035827 in SearchDlg::qt_invoke () from /usr/lib/libkdeinit_kerry.so
#28 0x4e381f17 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0x4e3829bc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#30 0x4e721f83 in QLineEdit::returnPressed () from /usr/lib/libqt-mt.so.3
#31 0x4e463b85 in QLineEdit::keyPressEvent () from /usr/lib/libqt-mt.so.3
#32 0x4ed24963 in KLineEdit::keyPressEvent () from /usr/lib/libkdeui.so.4
#33 0x4e3b8f0b in QWidget::event () from /usr/lib/libqt-mt.so.3
#34 0x4e4631c3 in QLineEdit::event () from /usr/lib/libqt-mt.so.3
#35 0x4e319148 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#36 0x4e31b118 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#37 0x4ea95f52 in KApplication::notify () from /usr/lib/libkdecore.so.4
#38 0x4e2ab9bd in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#39 0x4e29c3a9 in QETWidget::translateKeyEvent () from /usr/lib/libqt-mt.so.3
#40 0x4e2a878f in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#41 0x4e2bf8e0 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#42 0x4e33381e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#43 0x4e33362e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#44 0x4e31acf1 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#45 0x41026499 in kdemain () from /usr/lib/libkdeinit_kerry.so
#46 0x4dafb8cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#47 0x080485e9 in ?? ()
-----------
Comment 1 Richard Moore 2007-05-07 14:38:25 UTC
Kerry was working well in Kubuntu Dapper, but crashes now that I have upgraded to Kubuntu Feisty.

My backtrace is:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232897824 (LWP 5948)]
[New Thread -1243386992 (LWP 8847)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb7d7005b in read () from /lib/tls/i686/cmov/libc.so.6
#2  0xb6a9dbee in ?? () from /usr/lib/libDCOP.so.4
#3  0x00000003 in ?? ()
#4  0x0808df78 in ?? ()
#5  0x00000008 in ?? ()
#6  0x0823adc0 in ?? ()
#7  0xbff23ca8 in ?? ()
#8  0xb6aa3844 in ?? () from /usr/lib/libDCOP.so.4
#9  0xbff23c98 in ?? ()
#10 0xb6a9d89f in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
Backtrace stopped: frame did not save the PC
Comment 2 Lars DIECKOW 2007-05-30 04:21:07 UTC
Confirming for version 0.2.2, though 0.2.1 crashes the same. This is openSUSE 10.2 with KDE 3.5.7 installed from vendor packages.

$ rpm -q kerry
kerry-0.2.2-32.1

$ kerry --version
Qt: 3.3.8
KDE: 3.5.7 "release 10.1"
Kerry Beagle-Suche: 0.2.2

The crash is always reproducable. How to reproduce:
* Start kerry, for example by typing kerry in konsole and confirming with Enter.
* Activate the kerry window and bring it to foreground, for example by pressing Alt+Space.
* Type a search item in the focussed search field, for example gjiten and confirm with Enter.

What should happen: show search results.
What really happens: show search results, then crash after about half a second with the following showing in konsole

** (process:21383): WARNING **: Unhandled element: NumMatches!

KCrash: Application 'kerry' crashing...
kerry: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 21383, errno = 104
kerry: xcb_xlib.c:42: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Unable to start Dr. Konqi

I suspect this is the fault at heart: <https://lwn.net/Articles/211808/>

Crashhandler backtrace:

 [?1034hUsing host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1235786032 (LWP 21383)]
[New Thread -1288881264 (LWP 21385)]
0xb7f06410 in ?? ()
#0  0xb7f06410 in ?? ()
#1  0xbfe28748 in ?? ()
#2  0x00000008 in ?? ()
#3  0x08056b20 in ?? ()
#4  0xb7e1c8ab in ?? () from /lib/libc.so.6
#5  0xb72df88e in _kde_IceTransSocketRead () from /opt/kde3/lib/libDCOP.so.4
#6  0xb72df55f in _kde_IceTransRead () from /opt/kde3/lib/libDCOP.so.4
#7  0xb72d8fef in _kde_IceRead () from /opt/kde3/lib/libDCOP.so.4
#8  0xb72ddbaf in KDE_IceProcessMessages () from /opt/kde3/lib/libDCOP.so.4
#9  0xb72c9419 in DCOPClient::callInternal () from /opt/kde3/lib/libDCOP.so.4
#10 0xb72c96fd in DCOPClient::callInternal () from /opt/kde3/lib/libDCOP.so.4
#11 0xb72ce147 in DCOPClient::call () from /opt/kde3/lib/libDCOP.so.4
#12 0xb72ce1a7 in DCOPClient::call () from /opt/kde3/lib/libDCOP.so.4
#13 0xb72ce3a8 in DCOPClient::disconnectDCOPSignal ()
   from /opt/kde3/lib/libDCOP.so.4
#14 0xb72ced19 in DCOPObject::~DCOPObject () from /opt/kde3/lib/libDCOP.so.4
#15 0xb67b586d in KRES::ManagerImpl::~ManagerImpl ()
   from /opt/kde3/lib/libkresources.so.1
#16 0xb7bea7c7 in KRES::Manager<KABC::Resource>::~Manager ()
   from /opt/kde3/lib/libkabc.so.1
#17 0xb7b95594 in KABC::AddressBook::~AddressBook ()
   from /opt/kde3/lib/libkabc.so.1
#18 0xb7bbf698 in KABC::StdAddressBook::~StdAddressBook ()
   from /opt/kde3/lib/libkabc.so.1
#19 0xb7b937e2 in __tcf_13 () from /opt/kde3/lib/libkabc.so.1
#20 0xb7d97ed1 in __cxa_finalize () from /lib/libc.so.6
#21 0xb7b876a3 in __do_global_dtors_aux () from /opt/kde3/lib/libkabc.so.1
#22 0xb7bf9acc in _fini () from /opt/kde3/lib/libkabc.so.1
#23 0xb7f15a4f in _dl_fini () from /lib/ld-linux.so.2
#24 0xb7d97bcd in exit () from /lib/libc.so.6
#25 0xb6d75d22 in qt_xio_errhandler () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb73b613d in KApplication::xioErrhandler ()
   from /opt/kde3/lib/libkdecore.so.4
#27 0xb73b6189 in kde_xio_errhandler () from /opt/kde3/lib/libkdecore.so.4
#28 0xb69969ed in _XIOError () from /usr/lib/libX11.so.6
#29 0xb699dfca in process_responses () from /usr/lib/libX11.so.6
#30 0xb699e338 in _XEventsQueued () from /usr/lib/libX11.so.6
#31 0xb6987c82 in XPending () from /usr/lib/libX11.so.6
#32 0xb6d94921 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6dfc7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb6dfc686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb6de557f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb7ed698a in kdemain () from /opt/kde3/lib/libkdeinit_kerry.so
#37 0x080484e2 in main ()
Comment 3 Wiliam VERCH-WELDON 2008-04-26 01:13:37 UTC
same happened to me. Kerry beagle crashed after half hour search time. No backtrace. caused signal 6 (SIGABRT):  0[?1034h (no debugging symbols) using host libthread_db library  "/lib/libthread_db.so.1"  Had frequently gotten message: "Warning: KDE Panel"  This is openSUSE 10.3 on i586 arc using vender dvd of kde 3.5.7 version 72.6.  Intel Celeron CPU. had also frequently been asked if wanted to shut down a long list (one at a time) of processes which were slowing down te system.
Comment 4 Lubos Lunak 2008-07-21 16:22:39 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 5 pier andre 2009-02-13 14:22:30 UTC
crashed after a search and show a confused and superpodsed output of founded files
this is the report
Applicazione: Ricerca Kerry Beagle (kerry), segnale SIGSEGV
   from /lib64/libpthread.so.0
[Current thread is 1 (Thread 0x7fdbdcc56750 (LWP 32025))]

Thread 3 (Thread 0x7fdbcd0cc950 (LWP 5399)):
#0  0x00007fdbd856e662 in select () from /lib64/libc.so.6
#1  0x00007fdbd92b8366 in ?? () from /usr/lib64/libQtCore.so.4
#2  0x00007fdbd91eff72 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007fdbd8f7c070 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fdbd857510d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fdbcafa0950 (LWP 8556)):
[KCrash Handler]
#5  0x00007fdbd9e58b7f in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /usr/lib64/libQtGui.so.4
#6  0x00007fdbd9e1e8e4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#7  0x00007fdbdc6a6b3b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#8  0x00007fdbd92d8091 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#9  0x00007fdbd9e1db98 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib64/libQtGui.so.4
#10 0x00007fdbd9e82019 in ?? () from /usr/lib64/libQtGui.so.4
#11 0x00007fdbd9e80f7a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007fdbd9ea71d4 in ?? () from /usr/lib64/libQtGui.so.4
#13 0x00007fdbdb18c0db in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#14 0x00007fdbdb18f8ad in ?? () from /usr/lib64/libglib-2.0.so.0
#15 0x00007fdbdb18fa6b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#16 0x0000000000414f19 in ?? ()
#17 0x00007fdbd91eff72 in ?? () from /usr/lib64/libQtCore.so.4
#18 0x00007fdbd8f7c070 in start_thread () from /lib64/libpthread.so.0
#19 0x00007fdbd857510d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdbdcc56750 (LWP 32025)):
#0  0x00007fdbd8f7fd59 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdbd91f0f29 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fdbd91f011c in QThread::wait(unsigned long) () from /usr/lib64/libQtCore.so.4
#3  0x00007fdbd92bb231 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fdbd92bb6f5 in ?? () from /usr/lib64/libQtCore.so.4
#5  0x00007fdbd84d72ed in exit () from /lib64/libc.so.6
#6  0x00007fdbd9e6ff28 in ?? () from /usr/lib64/libQtGui.so.4
#7  0x00007fdbd7d86e54 in _XIOError () from /usr/lib64/libX11.so.6
#8  0x00007fdbd7d8ef48 in _XSend () from /usr/lib64/libX11.so.6
#9  0x00007fdbd7d8f02d in _XFlush () from /usr/lib64/libX11.so.6
#10 0x00007fdbd7d6658a in XFlush () from /usr/lib64/libX11.so.6
#11 0x00007fdbd9e96b8f in QWidgetPrivate::hide_sys() () from /usr/lib64/libQtGui.so.4
#12 0x00007fdbd9e630e3 in QWidgetPrivate::hide_helper() () from /usr/lib64/libQtGui.so.4
#13 0x00007fdbd9e6bb10 in QWidget::setVisible(bool) () from /usr/lib64/libQtGui.so.4
#14 0x00007fdbd9e697c0 in QWidget::~QWidget() () from /usr/lib64/libQtGui.so.4
#15 0x00007fdbd9e92ee1 in QDesktopWidget::~QDesktopWidget() () from /usr/lib64/libQtGui.so.4
#16 0x00007fdbd9e1f99c in QApplication::~QApplication() () from /usr/lib64/libQtGui.so.4
#17 0x0000000000416ed9 in ?? ()
#18 0x00000000004146ac in ?? ()
#19 0x00007fdbd84c0586 in __libc_start_main () from /lib64/libc.so.6
#20 0x0000000000413fe9 in _start ()

Comment 6 Jekyll Wu 2012-11-09 16:11:27 UTC
Kerry is unmaintained