Bug 143230 - Reminders for imported birthdays from KAdressbook don't work as expected
Summary: Reminders for imported birthdays from KAdressbook don't work as expected
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-19 20:04 UTC by Tobias
Modified: 2007-07-17 16:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Proposed patch to correctly set the reminder time for imported birthdays (826 bytes, patch)
2007-07-15 12:26 UTC, Tobias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias 2007-03-19 20:04:02 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

I have imported the birthdays of my contacts by adding the "Birthdays from KAdressbook" resource to KOrganizer (since I use the German version I don't know the exact name of it). I then set it up to remind me 3 days in advance. However the reminder dialogs for the birthdays only pop up on the day of the birthday and not 3 days in advance as expected.
Comment 1 Tobias 2007-04-18 06:59:19 UTC
Has anybody reproduced this?
Comment 2 Olivier Vitrat 2007-04-25 20:42:09 UTC
This has been also reported in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=420826
Comment 3 Tobias 2007-04-26 07:01:30 UTC
I can confirm that the workaround mentioned in the Debian bug report works for me, too. Setting it to 3*60 days in advance gives me the warning 3 days in advance. So this should be an easy fix.
Comment 4 Tobias 2007-05-24 07:01:19 UTC
Now KDE 3.5.7 is out and it was said that there were especially PIM bugfixes but this still doesn't seem to be fixed. Why is that? It seems like a really easy fix...

Tobias
Comment 5 Bram Schoenmakers 2007-06-07 09:43:52 UTC
> Why is that?

No one seems to find it important enough.

> It seems like a really easy fix... 

You know the code? Then send us a patch, please, and we'll apply it.
Comment 6 Tobias 2007-07-15 12:26:20 UTC
Created attachment 21153 [details]
Proposed patch to correctly set the reminder time for imported birthdays
Comment 7 Tobias 2007-07-15 12:28:16 UTC
Sorry,  forgot to write the comment when uploading the patch. This is the first time I created a patch so I hope I did everything right. I haven't tested it because I'm not sure how to compile kdepim from svn on my system. Maybe someone could point me to more information? I'd be happy to be of more help.

Tobias
Comment 8 Allen Winter 2007-07-17 16:46:31 UTC
SVN commit 689074 by winterz:

Fix Reminders for imported birthdays from KAdressbook don't work as expected

Thanks for the patch Tobias.
BUGS: 143230


 M  +4 -4      resourcekabc.cpp  


--- branches/KDE/3.5/kdepim/kresources/birthdays/resourcekabc.cpp #689073:689074
@@ -200,8 +200,8 @@
         Alarm* vAlarm = ev->newAlarm();
         vAlarm->setText(summary);
         vAlarm->setTime(birthdate);
-        // 24 hours before
-        vAlarm->setStartOffset( -1440 * mAlarmDays );
+        // 24 hours before. duration is in seconds.
+        vAlarm->setStartOffset( -86400 * mAlarmDays );
         vAlarm->setEnabled(true);
       }
 
@@ -305,8 +305,8 @@
       Alarm* vAlarm = ev->newAlarm();
       vAlarm->setText(summary);
       vAlarm->setTime(anniversary);
-      // 24 hours before
-      vAlarm->setStartOffset( -1440 * mAlarmDays );
+      // 24 hours before. duration is in seconds.
+      vAlarm->setStartOffset( -86400 * mAlarmDays );
       vAlarm->setEnabled(true);
     }