Bug 142981 - Deleting an image from album gui denied
Summary: Deleting an image from album gui denied
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-Trash (show other bugs)
Version: 0.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-14 21:37 UTC by Caspar Maessen
Modified: 2022-01-12 03:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caspar Maessen 2007-03-14 21:37:03 UTC
Version:           0.9.2-svn (using KDE 3.5.6 "release 31.4" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.1-default

Today I noticed that a plain <Delete> doesn't work anymore. It gives the message: "Access denied to trash:/filename.jpg". <Shift>+<Delete> works OK!
<Delete> from within konqueror gives no problems.
Comment 1 caulier.gilles 2007-03-14 21:46:05 UTC
Caspar,

If you use Gnome, the problem have been reported recently in Mailing list.

Gilles
Comment 2 Caspar Maessen 2007-03-14 23:15:46 UTC
KDE 3.5.6 "release 31.4" openSUSE

Caspar.
Comment 3 Caspar Maessen 2007-03-19 19:43:12 UTC
Just tested the latest svn-version. No luck.

As Gilles suggested I also looked up the thread in the archives. But 
since I use KDE, nothing mentioned there applies to my situation, As I 
stated before, the delete-key is working as it should under Konqueror 
as is the kio-slave. Entering trash:/ in Konqueror or in the 
file-dialog of Kate gives me access to the trashcan. So this leads to 
the assumption that it is something in digiKam.

Being able to move files to trash with one keystroke (and so being able 
to recover) is essential to my workflow. Therefore I hope this one is 
solved shortly.

Thanks.

Caspar.
Comment 4 Geoff King 2007-03-22 03:03:44 UTC
I've got the same problem with today's svn version.  Can't delete anything unless shift-delete from keyboard.  I've verified rw access to this file. 
Comment 5 caulier.gilles 2007-03-22 05:37:01 UTC
I  confirm this bug. i can reproduce on my computer.

Marcel, it sounds like a bug in kio-slave. right ?

Gilles
Comment 6 Marcel Wiesweg 2007-04-01 13:42:16 UTC
It's probably due to my recent change passing digikamalbum:/ URLs to the slave. I will have a look at it.
Comment 7 caulier.gilles 2007-04-01 13:52:49 UTC
Yes, Marcel...

Try to provide to Achim a patch against 0.9.1 stable to fix current packages...

Gilles



Comment 8 Marcel Wiesweg 2007-04-02 22:17:44 UTC
SVN commit 649549 by mwiesweg:

This, and commit 649547 which is missing a commit message, is for the trash:/ problem:
The trash:/ ioslave does not have implemented its put method, it only likes local files.

CCBUG: 142981


 M  +5 -0      imagewindow.cpp  


--- trunk/extragear/graphics/digikam/utilities/imageeditor/editor/imagewindow.cpp #649548:649549
@@ -897,6 +897,7 @@
         kioURL = d->imageInfoCurrent->kurlForKIO();
     else
         kioURL = d->urlCurrent;
+    KURL fileURL = d->urlCurrent;
 
     if (!palbum)
         return;
@@ -927,6 +928,10 @@
     // bring all (sidebar) to a defined state without letting them sit on the deleted file
     emit signalNoCurrentItem();
 
+    // trash does not like non-local URLs, put is not implemented
+    if (useTrash)
+        kioURL = fileURL;
+
     if (!SyncJob::del(kioURL, useTrash))
     {
         QString errMsg(SyncJob::lastErrorMsg());
Comment 9 Arnd Baecker 2007-06-12 21:21:40 UTC
Caspar, Marcel:

shouldn't this bug be closed after Marcel's patch,
or is there still a problem?

Thanks a lot,

Arnd
Comment 10 Caspar Maessen 2007-06-12 21:59:48 UTC
Works fine now.

Caspar.