Bug 142475 - Bug with auto-completion of references
Summary: Bug with auto-completion of references
Status: RESOLVED FIXED
Alias: None
Product: kile
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-03 20:33 UTC by Nikos Platis
Modified: 2007-03-27 17:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Platis 2007-03-03 20:33:26 UTC
Version:           1.9.2 (using KDE KDE 3.5.6)
Installed from:    Unspecified
OS:                Linux

Sometimes auto-completion of references completes the wrong text. It seems to be happening in very specific situations:
a) Create a label "\label{Eq:ThisIsAnEquation}"
b) Compile or save, so that the list of labels is refreshed
c) Try to reference this label by typing "\ref{ <ENTER>" (to auto-complete the command and open the dropdown list of labels)
d) Type "Eq:Thi <ENTER>" to see "\ref{Eq:ThiThisIsAnEquation} !

The issue is that Kile seems to repeat some characters of the label. I strongly suspect that this has something to do with the label containing ":". It only seems to happen if I type some characters after the ":" of the label before hitting <ENTER> to perform the auto-completion.
Comment 1 Holger Danielsson 2007-03-27 17:49:57 UTC
Thank you for your bug report.

The bug that you reported has been identified and fixed in the latest 
development (SVN) version of Kile.

cio holger