Bug 142423 - folder loss when `move folder to ...' action be undone with ctrl-Z
Summary: folder loss when `move folder to ...' action be undone with ctrl-Z
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.3
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-02 23:04 UTC by Michael Mounteney
Modified: 2007-06-09 14:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mounteney 2007-03-02 23:04:42 UTC
Version:           1.9.3 (using KDE KDE 3.5.3)
Installed from:    Gentoo Packages
Compiler:          GCC 3.4.4 i686-pc-linux-gnu-gcc (GCC) 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8)
OS:                Linux

All local folders.

Create a parent folder (in my case, called `incoming').  Create a mail folder within this (in my case, `2007').  Right-click on the mail folder and select `move folder to ...', local folders, This folder.  The mail folder is moved as specified.

Menu: Edit/undo.  Kmail crashes.

Re-start Kmail.  The mail folder (`2007') is lost.  It does not exist under the .kde/apps/share/kmail hierarchy.  It has been entirely deleted.
Comment 1 Bram Schoenmakers 2007-03-03 00:30:40 UTC
Please paste a backtrace here of the crash, if it contains usable data.
Comment 2 Thomas McGuire 2007-06-09 14:51:46 UTC
No respone from the reporter.
Additonally, I couldn't reproduce it, it doesn't crash for me.