Bug 142380 - kmail ssl imap/smtp fail with kerberos installed
Summary: kmail ssl imap/smtp fail with kerberos installed
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: imap (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-01 20:03 UTC by D. Kevin McGrath
Modified: 2010-01-03 23:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D. Kevin McGrath 2007-03-01 20:03:00 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Compiled From Sources
Compiler:          gcc (GCC) 4.1.1 (Gentoo 4.1.1-r3)
 
OS:                Linux

On an up to date gentoo installation, if the app-crypt/mit-krb5 ebuild is installed, kmail becomes unable to use SSL enabled IMAP or SMTP, and fails with an error of 

"The process for the imaps://mail.server protocol died unexpectedly." 

or 

"The process for the smtps://mail.server protocol died unexpectedly."

After trying to reinstall kdepim, kdelibs, and kdebase, the solution turned out to be simply uninstalling the kerberos package.  While this workaround exists, it is unsatisfactory, as my setup requires a kerberized ssh client.

The problem reappeared upon reinstallation of kerberos.

How to reproduce:
On an up to date gentoo system, install KDE as well as mit-krb5, or just enable the kerberos use flag.
Comment 1 Thomas McGuire 2007-03-31 22:44:53 UTC
Is this maybe the same thing as in bug 139944?
What were you exactly doing when the error occured?
Comment 2 D. Kevin McGrath 2007-03-31 22:53:01 UTC
I don't believe it is the same thing, as I have kwallet already open  
and accessible to kmail when I launch kmail.  Also, if I try to use  
the imaps kpart (I think that's the right term) from konqueror, I get  
exactly the same error.

And as far as I know, I wasn't doing anything special when it died.   
I had just updated the system, including SSL, but all other SSL  
applications still work, including KDE apps like kopete.  I tried  
updating to the newest kdelibs and kdepim, to no avail.

Now it is dead regardless of whether I have kerberos installed, so I  
have no idea what the problem is.  Maybe I just have a corrupt file.   
What file in particular controls this function in kmail?  Is there a  
library, an app, or what?

thanks,
Kevin

On 31 Mar 2007, at 4:44 PM, Thomas McGuire wrote:

[bugs.kde.org quoted mail]
Comment 3 Thomas McGuire 2007-03-31 23:19:43 UTC
>Also, if I try to use the imaps kpart (I think that's the right term) from konqueror, I get exactly the same error. 
It's called kioslave. I'll reassign this to kio then.
Comment 4 Dallas Masters 2007-05-04 19:40:55 UTC
I am experiencing this same problem on my gentoo system with kerberos.  How do find out if it's been resolved by the kio group?  I cannot find any mention of kerberos problems anywhere else.
Comment 5 Thomas McGuire 2007-05-07 18:19:19 UTC
>How do find out if it's been resolved by the kio group?
If the bug is fixed, this report will get closed. So far, it is not fixed.
Comment 6 Thomas McGuire 2007-12-12 23:37:53 UTC
Reassigning the bugs of the SMTP, IMAP and POP ioslaves to kdepim-bugs.
Comment 7 Thomas McGuire 2007-12-12 23:49:19 UTC
Undo autoconfirm. Sorry.
Comment 8 Will Saxon 2008-02-09 09:17:14 UTC
I am having this exact same issue with my gmail account and Kmail. I also have the same issue when I try to download my INBOX using konqueror and the imaps://imap.gmail.com url. 

I am using a brand-new installation of Gentoo Linux, with KDE 3.5.8 built from source. I do _not_ have mit-krb5 installed.
Comment 9 Will Saxon 2008-02-10 08:27:02 UTC
Take a look at http://bugs.kde.org/show_bug.cgi?id=111259 - I think this may actually be the same problem. 
Comment 10 Björn Ruberg 2010-01-03 21:09:46 UTC
As bug 111259 this may be fixed in recent kmail. Can anybody confirm this bug still exists in KDE 4.3+?
Comment 11 Will Saxon 2010-01-03 23:50:33 UTC
It has not happened for me with 4.3+ kmail.